What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Why can't I add a graphic?

    Asked by cmemanage on February 10, 2015 at 01:32 PM

    The Image function on my forms seems to be broken. Every time I go through the wizard, I select "Enter URL" and then "Next," but I keep getting an error message saying "Please select a type first." It won't let me continue. See the screen shot for an example.

     

    I tried this twice: I tried replacing an old image with the wizard that was already there, then I deleted that one and pulled a new Image tool over from the left-hand side. It didn't work either time.

    Page URL:
    http://form.jotformpro.com/form/50395997032968

    Screenshot
    My Forms message image tool next
  • Profile Image
    JotForm Support

    Answered by david on February 10, 2015 at 02:24 PM

    Hi,

    I checked the image tool in a cloned version of your form and it appears to be working properly.  When I click on next after selecting "Enter URL" I am brought to this screen, where I can enter the URL:

    I was then able to add the image without issue.  I would recommend clearing your browsers cache/cookies to see if that helps.  There may be some old code loading that is interfering with your form in the builder.

    If you are still unable to add images to your form, let us know what browser you are using and we will be happy to have another look.