What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Form Calculation is not calculating the fields, just showing their values

    Asked by clo1973 on February 11, 2015 at 04:40 AM

    I created a simple form with 4 questions collecting 4 separate numbers.  On a last field, I used the form calculator to multiply these four numbers from the previous 4 questions.  

    What is happening is that output field is only passing the values of each of the 4 fields without doing the math calculation.

    Here is my form:  http://form.jotform.us/form/50408382475154

     

    Thank you for your help.

     

    Page URL:
    http://form.jotform.us/form/50408382475154

    Screenshot
    math form calculator
  • Profile Image

    Answered by Ben on February 11, 2015 at 09:26 AM

    I went to the tab "5" and filled out the fields above the Form calculation, but every time I did so, it had calculated the value properly.

    Is this by some chance happening on your website - after you have embedded the jotform?

  • Profile Image

    Answered by clo1973 on February 11, 2015 at 01:00 PM

    Hi Ben,

    I was pleasantly surprised that this morning, the calculated fields worked just fine.  I gave up last night after a long time of trying multiple things.  I didn't change a thing on the form and the calculations worked fine suddenly.

     

  • Profile Image

    Answered by Ben on February 11, 2015 at 01:39 PM

    I am glad to hear that it is working, but I am not sure what might be the reason that it did not work yesterday.

    Sometimes it could be caused by the cache in the browser if we make a lot of changes to the jotform - this is something people developing some code know well and very often clear it just for such reasons.

    If it by some chance happens again, do let us know and we would be happy to take a look at what might be the issue.