My form is running very slow and it freezes in some occasions

  • Profile Image
    danzegallery
    Asked on February 13, 2015 at 05:01 PM

    I have 2 identical forms. Only difference is one is paypal the other is purchase order. The purchase order form is running fine, but the paypal form is running too slowly, even freezing. What causes this.

  • Profile Image
    raul
    Answered on February 13, 2015 at 06:53 PM

    Are you referring to this form: http://www.jotformpro.com/form/50240809967966?

    If so, I was unable to reproduce the issue.
    Your form loaded in 11 seconds and I'm using an ADSL connection so it's a pretty decent time for my speed connection.

    Could you please try to clear your browser's cache to see if it helps? If possible, try to load your form on different browser/devices.

    Let us know if the issue persists.
    Thank you.

  • Profile Image
    danzegallery
    Answered on February 13, 2015 at 07:33 PM

    It seems to load quickly enough, but when you start filling it in it becomes very slow between fields. It is not only on my computer bt on other peoples computer as the form is live. I have another identical form which is a cash entry form and that runs well. I was considering deleting the form and cloning the cash form and changing it to paypal. Maybe there is something small in the paypal form that is causing my problems.

  • Profile Image
    Sean
    Answered on February 14, 2015 at 12:27 AM

    It is possible that your form cache can be causing this. I have taken the initiative to clear your form cache to see if it will address your issue. Do let us know if anything changes.


    Thank you 

  • Profile Image
    danzegallery
    Answered on February 14, 2015 at 12:49 AM

    Problem is still there. I have other forms almost identical to these (disabled at present) and they seem to run well. Maybe I have done something wrong which is slowing up the filling out of the form.

  • Profile Image
    Sean
    Answered on February 14, 2015 at 08:04 AM

    Just to confirm this is the form in question, correct?
    http://www.jotformpro.com/form/50240809967966

    I checked your form and I was able to replicate your issue. I had a second or 2 delay in between different field selections. Now, I realize that you have quite a few options with check boxes.



    This can be the reason why this is happening. I would recommend using one of these multi-select widgets to replace your check boxes.

    http://widgets.jotform.com/widget/dual_listbox

    http://widgets.jotform.com/widget/visual_multi_select

    Do give this a try and do let us know how it goes.

    Thank you