What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Settings cog and delete buttons of form fields not being displayed in Chrome

    Asked by trybedo on February 15, 2015 at 06:05 PM

    When I use Google Chrome, the settings wrench and the x delete button do not appear on any of the form tools. It works in Explorer but not in chrome. How can I fix this?

    form tools settings tools settings button delete button
  • Profile Image
    JotForm Support

    Answered by abajan on February 15, 2015 at 10:36 PM

    Unfortunately, I'm unable to replicate this issue. I use Chrome almost exclusively with the form builder and even when I just checked, the wrench (cog) and x button appeared just fine. Are you referring to the buttons shown below?


    If so, perhaps it's related to a specific version of Chrome. Which one are you using and on which device?

  • Profile Image

    Answered by trybedo on February 26, 2015 at 07:06 PM

    So how does that help me?

    I use Chrome on various devices. It works intermittently. I have updated to the latest versions. 

    Right now I am using a Dell PC with windows 8.1, core i3, touch screen.

    I really need help and I tried to ask again but got nowhere because I asked again. 

  • Profile Image

    Answered by Sean on February 26, 2015 at 09:06 PM

    I tested it also and I was not able to replicate the issue. Are you not seeing it when you use the touch screen feature on your Dell PC?

    Perhaps clearing your browser cache might help. Here is a guide that you can follow: http://pcsupport.about.com/od/browsers/f/clear-cache.htm 

    Please let us know the outcome.


    Thank you.

  • Profile Image

    Answered by trybedo on February 26, 2015 at 09:15 PM

    I'm not really sure how to explain this to you. It just doesn't show up. I've done everything I can think of including your suggestion of clearing the cache, clearing the history and cookies, making sure I had the latest version of chrome. I know you are not able to replicate the issue. It doesn't mean it's not happening. 

  • Profile Image
    JotForm Support

    Answered by BDAVID on February 26, 2015 at 10:24 PM

    I hadn't noticed that on my Chrome browser since I use more FireFox for testing purposes, but I was able to replicate the issue, it happens on my Chrome too.

    See screenshot below, they do not appear upon doing a left click(as it does in other browsers). In the mean time, the solution would be  doing a right click on the fields:

    I will report this to our second level for further inspection. You will be updated about this matter via this thread.

    If you need anything else, please open a new thread, we will be glad to assist you.

  • Profile Image
    JotForm Founder

    Answered by aytekin on February 27, 2015 at 09:01 AM

    I am not sure why David did not post this here but he was able to re-create the problem:

  • Profile Image

    Answered by candycartons on December 01, 2015 at 09:11 AM

    Has this been resolved? This is a MAJOR issue. You must be losing lots of business from frustrated Chrome users.

    Guess I gotta dust off old IE for editing =(.

  • Profile Image

    Answered by Ben on December 01, 2015 at 11:28 AM

    Unfortunately there is no update on this issue at this time, but in my experience, you would need to do a double tap on your touch screen instead of just once to see the same.

    *At least on older mobile chrome browsers - it was a case that when you tap the screen once, it shows you the hovering effect, instead of the click effect. However double tap on the screen would made it do both and should allow you to see the cog.

    Do let us know how it goes.

  • Profile Image

    Answered by candycartons on December 01, 2015 at 11:32 AM

    Tried double tapping to no avail. BUT, if I tap my screen on the upper right edge of the bounding box for the particular element, the cog will appear. Click with the mouse does not work at all. Must touch edge of bounding box on touch screen.

    Windows 8, Chrome, touchscreen computer.

  • Profile Image

    Answered by Ben on December 01, 2015 at 12:55 PM

    After you posted your reply I thought of checking something and I think that I see the issue with my FireFox as well, although it is not clearly noticeable at first.

    I forced some additional styles to be applied so that this is illustrated better so that it might help our developers with this.

    Here is the screen cap:

    I basically made it turn into red letters with red border when hover does not get activated properly, while when it does get activated, it is showing dashed border instead.

    The red rectangle in the element itself is the one that is always capturing the mouse.

    I will leave a comment about this to my colleagues in regards to this, but to me this explains why sometimes the tap is not being captured - since as I mentioned above, tap will first activate the hover effect.

    If you go over the same field fast, then there are no such issues, nor if you click on the element.

    One thing that I would like to ask you is if you can tap, and leave the finger on the screen (hold it there for a second or two)?

    Do let us know how it goes.