What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Payment Tool / Calculation Widget: When the "ignore hidden fields" option is enabled the payment tool shows a zero value instead of the widget's value

    Asked by djccraig on February 18, 2015 at 02:52 PM

    Hello!

    I'm using a form calculation field "OVERALL TOTAL:" that is supposed to pass through a total to the Authorize.net payment widget. 

    However, when I select the "Ignore Hidden Fields" option on this calculation field, the Authorize.net payment amount shows "$0".

    Thanks for your help!

    Page URL:
    http://form.jotformpro.com/form/50485902685968

    hidden form calculation select thanks
  • Profile Image

    Answered by raul on February 18, 2015 at 04:38 PM

    I've cloned your form for testing purposes and was unable to reproduce the issue.
    I made several combinations and was always able to see an amount on the payment gateway.

    Are you referring to this field or the actual charge made on Authorize.net? Could you also please try to clear your browser's cache to see if it helps?

    Thank you.

  • Profile Image

    Answered by djccraig on February 18, 2015 at 04:49 PM

    Thanks for your help. 

    I cleared my cache, and also tried this on another computer, and I'm still getting this issue:

    Can you please try using this exact form: http://form.jotformpro.com/form/50485902685968

    And see if you get something other than $0 on the payment page?

    Thanks!

  • Profile Image

    Answered by raul on February 18, 2015 at 06:20 PM

    I was able now to reproduce the issue using a cloned version of your form but when I created a new one from scratch it worked as expected.

    Please allow me some time to make further tests to see if I'm able to find the reason of this and will get back to you as soon as I can.

    Thank you.

  • Profile Image

    Answered by raul on February 18, 2015 at 08:43 PM

    Unfortunately, I was unable to find the reason of why this is happening in your form. Thus, I'm sending this thread to our back end so they can take a look at it and provide assistance.

    Please allow some time for them to evaluate this issue and you'll be notified here once they have a response for you.

    Thank you.