Submission date includes apostrophe before the date start in Google Spreadsheet integrations

  • Profile Image
    kcboiatc
    Asked on February 23, 2015 at 04:51 PM

    I recently setup a form and integrated it with Google Sheets. It was working great until Feb 18. My date data from the form is showing up in google sheets as " '2015-02-18 20:18:17" due to the " ' " preceding the date, I am unable to sort my data ascending by date. This is happening with any dates involved with my form.

    Before Feb 18 the date submitted "2015-02-18 20:18:17" no apostrophe . Please help!

     

     

     

  • Profile Image
    Ben
    Answered on February 23, 2015 at 06:22 PM

    Thank you for reporting this to us.

    I am able to recreate the exact issue that you have described.

    I am now raising this to our developers and as soon as there are any updates in regards to this you will be updated about it through this thread.

  • Profile Image
    Ben
    Answered on February 23, 2015 at 06:28 PM
     
  • Profile Image
    alp_deniz
    Answered on February 26, 2015 at 12:17 AM

    Hello,

    Actually the apostrophe is intentional: It is used for consistency in spreadsheets in order to keep the format. Otherwise the sheet itself modifies the date string according to the default format.

    As for the solution, it is always possible and reliable to use Format -> Number -> Date [desired format]. Does it work for you? Would you have a suggestion?

    I will be very happy to hear your thoughts.

    Kind regards

    Alp

  • Profile Image
    kcboiatc
    Answered on February 27, 2015 at 05:00 PM

    It does not work because the apostrophe prevents google sheets from recognizing it as a date. When I started the form the dates imported to google sheets with no apostrophe preceding it... For what ever reason it started submitting as     '2015-02-24 22:35:48 You try to enter dates preceded by an apostrophe in google sheets and let me know if you can sort the data by date. I can not until I go in and remove the apostrophe. I have other sheets in the workbook that reference the submitted data, when I try to use a formula to extract a date, it will only do it when there is NO APOSTROPHE.

    We ( I think I speak for most spreadsheet users) would always prefer to modify the date format as we want it... not how you think we do. Please please please remove the apostrophe. It does not do me any good and it creates a lot of work.

    I appreciate you and the JotForm team work and efforts - please help me accomplish this change. 

  • Profile Image
    Mike
    Answered on February 27, 2015 at 06:10 PM

    Thank you for your explanation. The ticket is still open and we will keep you updated.

  • Profile Image
    kcboiatc
    Answered on February 27, 2015 at 06:26 PM

    Thank you.

  • Profile Image
    alp_deniz
    Answered on April 10, 2015 at 04:25 PM

    Hello,

    The issue is resolved and apostrophe is removed. Thank you very much for your notification.

    All the best

  • Profile Image
    kcboiatc
    Answered on April 13, 2015 at 10:51 AM

    That works perfect, no more apostrophe on the form submission date!, However... there is still an apostrophe being sent when the user selects a date from a form field. I still encounter the same issue as before when trying to include that data in a formula. 

    Is there anyway you can remove the apostrophe from all data submitted that includes a date? 

    Thanks again!

     

  • Profile Image
    Ben
    Answered on April 13, 2015 at 12:17 PM

    Great to hear that it worked :)

    I will update Alp (our developer) in regards to this so that he can take a look if the same can be done for all dates as per your request.

    As soon as there are any updates, we will update you through this thread.

  • Profile Image
    chantinon
    Answered on April 17, 2015 at 03:13 PM

    This problem is back  :/
  • Profile Image
    Malcolm 
    Answered on October 19, 2016 at 03:11 PM

    Yes, its back.  Cant use date picker to correct it in my form bc the date displays the wrong way when the form responses are sent into my doc template.