What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Form Conditions are not working properly

    Asked by otkweb on March 01, 2015 at 05:36 AM

    Hi JotForm Support,

    Some of my forms, whose condition settings previously working fine now suddenly not working. The attached form URL is one of the examples. I doubt that it caused by the priority setting problem as it was all the while tested OK and running fine unless your development team had made some changes on the program logic recently.

    Please help me to investigate and let me know what should I do to fix them. For the given form URL, all conditions should be executed accordingly on form load event. On form load before any account name is selected, only the status (Select your Account Name to check.) is appeared. The status and/or other field data should change when the account name changed. Please check.

    Thanks.

    EDIT: Many other forms with conditions are not working as well. Please take IMMEDIATE ACTION to resolve issues ASAP. Thank you.

    Page URL:
    http://form.jotform.me/form/41452893764464

    previously My Forms JotForm problem name
  • Profile Image

    Answered by jprentalhk on March 01, 2015 at 08:10 AM

    urgent, i had few forms also got the problem. please fix it asap.
  • Profile Image

    Answered by raul on March 01, 2015 at 11:36 AM

    @otkweb

    I've moved your condition to the top position on the list of conditions and resaved it and it seems to be working fine now.

    Please check it out at your side and let us know if the issue persists.
    Thank you.

    @jprentalhk

    I've moved your inquiry to a separate thread so we can address it properly. You can find it here: https://www.jotform.com/answers/524762

    Thank you.

  • Profile Image

    Answered by otkweb on March 01, 2015 at 11:54 AM

    Thanks Raul, but how about the rest of the forms? How about this one:

    http://form.jotform.me/form/41380427594458

    Expected Conditional Behaviors:

    1. The priority category and red text should not appear on form load.

    2. When 'Global Corporate Academy Sdn Bhd' account name is selected, Training Category should not appear but the Priority Category and red color text. Others will hide the Priority Category and red text again.

    So how are we going to resolve this? Can we change the priority order of the conditions ourselves without the help of your support team? Can you please tell us why this problem suddenly aroused???

    Thanks!

  • Profile Image

    Answered by mikemarinos on March 01, 2015 at 01:10 PM

    FORM CONDITIONS HAVE STOPPED WORKING

    Forms working as late as yesterday but today all conditions in forms have stopped working. Example http://form.jotformpro.com/form/42310612629952

    I have cleared both Jotform and browser cache. Tested in IE, Firefox and chrome all same problem. Have had customers review from different location (Different IP Address) same problem. Conditions not working.

    Have deleted conditions in form above and re-entered condition and "Finished, some condition.

    Look forward to your urgent assistance.

    WGL

     

  • Profile Image

    Answered by raul on March 01, 2015 at 01:48 PM

    @otkweb

    I was able to reproduce the issue on my side, but, unfortunately, I was unable to find a workaround to make the conditions in that form work correctly. Thus, I'm escalating this thread to our backend so they can have a look to it and provide assistance.

    You'll be notified here once they have a response for you.

    Thank you.

    @mikemarinos

    I've moved your report to a separate thread so we can address it properly. You can find the new thread here: http://www.jotform.com/answers/524789

    We'll also forward it to our back end team if necessary.

    Thank you.

  • Profile Image

    Answered by otkweb on March 01, 2015 at 06:17 PM

    mikemarinos was right on "Forms working as late as yesterday but today all conditions in forms have stopped working" and my problem is exactly the same too. Same problem but why is it that it has to be moved to a different thread? -- You guys have "unlimited support resources" to handle the same problem in an individual user basis??? By the way, why you guys always like to change users' forum post title????? Where is the word 'URGENT' there??? My original post title:

    "URGENT: Form Conditions Previously Working Fine Now Not Working"

    You guys better get all forms' conditions of all users back to work as normal I tell you!

  • Profile Image

    Answered by otkweb on March 01, 2015 at 09:30 PM

    Thanks!