What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Conditions in forms have stopped working

    Asked by mikemarinos on March 01, 2015 at 01:14 PM

    FORM CONDITIONS HAVE STOPPED WORKING

    Forms working as late as yesterday but today all conditions in forms have stopped working. Example http://form.jotformpro.com/form/42310612629952

    I have cleared both Jotform and browser cache. Tested in IE, Firefox and chrome all same problem. Have had customers review from different location (Different IP Address) same problem. Conditions not working.

    Have deleted conditions in form above and re-entered condition and "Finished, some condition.

    Look forward to your urgent assistance.

    WGL

    condition logic condition logic show
  • Profile Image
    JotForm Support

    Answered by jonathan on March 01, 2015 at 04:04 PM

    I was able to reproduced the issue with the Conditional Statements not working on the form http://form.jotformpro.com/form/42310612629952.

    Even on the cloned form http://www.jotformpro.com/form/50596139565970 the condition was not working even after correcting it already.

    Example, the field is always shown no matter what the option was, when it suppose to be hidden by default.

     

    I have submitted a bug ticket report to our higher team support to check on the issue.

    For the mean time, the workaround I have found that make the conditional statement work again, is by deleting first all of the conditional statement on the form and re-creating them.

    Example new form http://www.jotformpro.com/form/50595780212960

     

    If ok with you, you can also try the workaround. You can clone your form for another backup copy and do the workaround test on the cloned version instead. This way the original form is still preserved as is.

    Hope this help. We will notify you for any update on the status of the issue.

    Thanks.

     

     

     

     

     

     

     

     

  • Profile Image

    Answered by mikemarinos on March 01, 2015 at 04:31 PM

    Thank you for your prompt reply.

    The condition error is the same for all conditions on the form. All conditions have stopped working.

    The only issue in cloning the form and re-creating the conditions is this URL address is noted on a number of web pages and documentation references.  There is considerable work involved in changing the form reference.

    As a clue, the form was working ok about 12 hours ago. Not what has changed since then.

    I hope the higher team can resolve the issue.

    WGL

  • Profile Image
    JotForm Support

    Answered by jonathan on March 01, 2015 at 04:55 PM

    Our developer have immediately addressed and fixed the issue.

    If you check and test again your jotform http://form.jotformpro.com/form/42310612629952

    I can see the condition statement example to be working now

     

    Please confirm if it is now working on your end.. or not.

    We will wait for your updates.

    Thanks.

  • Profile Image

    Answered by mikemarinos on March 01, 2015 at 07:03 PM

    Thank you  jonathan

     

    What caused the problem?

    WGL

  • Profile Image

    Answered by mikemarinos on March 01, 2015 at 07:21 PM

    Thank you we have tested and it is now working ok.

    WGL

  • Profile Image
    JotForm Support

    Answered by ashwin_d on March 02, 2015 at 03:22 AM

    Hello mikemarinos,

    On behalf of my colleague, you are welcome. 

    I am glad to know that your form is working as expected. 

    Do get back to us if you have any questions.

    Thank you!