Our form is broken again, the submit button is missing, and we can't edit the form

  • Profile Image
    DEMagency
    Asked on March 05, 2015 at 02:28 PM

    This is the 2nd time in a row that a form has become broken. We had 150 entries this morning then it suddenly stopped.  when clicking on the form http://bit.ly/1DAhVAq  the submit button is now missing as well as part of the last HTML section.  This is what happened to our last form for this client.  I couldn't even duplicate the last form we created.  We submitted support tickets and haven't had any response in more than a week.  I recreated the first broken from and now the new form has the same issue. With 1000 entries per month available and only 150 used, there is something else that is going wrong.  The form is the jotform hosted form and not embeded into our client's website.

    I have not opened up an account with formsite.com to continue this marketing campaign for my client.  I can't continue to use jotform for my marketing agency if the product continually breaks down, and there is no response from support.  Please look into this urgently and contact me.

     

    Lee Nakamoto

    lee@thenerdbot.com

  • Profile Image
    Shadae
    Answered on March 05, 2015 at 04:01 PM

    Hi Lee,

    I do apologize for the issue that you are experiencing with your form.

    Unfortunately, I was not able to locate any post made regarding this issue. We do apologize that the issue was not previously addressed.

    After reviewing your form, I am seeing that the form is displaying correctly.

    Please attempt to clear your browser cache and access the form once again. Please inform us if the issue continues.

    Thank you.