Email notifications are not being received to my email account

  • Profile Image
    ipbr21054
    Asked on March 09, 2015 at 09:04 AM

    Hi,

    I have been told by customers that they are sending requests but i am not receiving emails.

    I have since sent say 6 test requests from my site but i have never received the email.

    Having said that if i log into my jotform account i can see all the requests there.

    This is the site in question http://www.theremotedoctor.co.uk/

     

    I have had my wife send me a few emails from her iphone to me and i have received each email no problem.

  • Profile Image
    Carina
    Answered on March 09, 2015 at 10:37 AM

    I checked our mail log and the email notifications are being sent: 

    Have you checked your spam folder? Maybe your email provider is blocking the emails as they come from a noreply address and it takes it as spam.

    I cloned the form, added a custom sender email and made a test submission. Can you please confirm me if you received it?

    If so you can consider adding a custom sender your email notification. You can see here more details.

    Let us know if the problem persists.

  • Profile Image
    ipbr21054
    Answered on March 09, 2015 at 11:44 AM

    Hi,

    Nothing in spam folder.

    Ive been receiving emails this morning from you no problem.

     

    Yes ive received your email.

  • Profile Image
    Charlie
    Answered on March 09, 2015 at 12:58 PM

    That's weird, could you try setting your SMTP using Mandrill instead? Here's a guide for that: http://www.jotform.com/help/240-Set-Email-Field-as-the-Notification-Sender-Email-Address-with-Mandrill

    You can also edit or delete existing SMTP settings here: http://www.jotform.com/help/241-How-to-Edit-Delete-Sender-Emails-on-SMTP-Settings.

    See if that works better. In our end it seems everything was sent properly as shown by our mail logs.

    Thank you.

  • Profile Image
    ipbr21054
    Answered on March 09, 2015 at 01:09 PM

    I have since added a custom sender email like advised and working fine.

    Please check it out.

  • Profile Image
    Charlie
    Answered on March 09, 2015 at 01:22 PM

    Hi,

    Could you tell us which of the submissions you see in your JotForm account that you did not receive an email notification?

    I understand you use the custom Sender email address using verification, is that right? I would still recommend using the Mandrill to set your SMTP details. 

    Do let us know if it changes anything.

    Thank you.

     

  • Profile Image
    ipbr21054
    Answered on March 09, 2015 at 01:35 PM

    Up until the last couple of hours take a look at the sent emails which show say 1 in each field.

    I was just using these as a test.

     

    Since receiving the advised post above i created the custome header etc and now receiving emails.

     

  • Profile Image
    Ben
    Answered on March 09, 2015 at 02:22 PM

    That is great to hear. If by some chance you are having issues receiving emails again, do let us know and we would be happy to check what might be the reason for that.

    I also went ahead and decreased your submissions to 19 to take away some that you have used for testing purposes.

  • Profile Image
    ipbr21054
    Answered on March 09, 2015 at 02:30 PM

    Thanks very much

  • Profile Image
    Ben
    Answered on March 09, 2015 at 02:38 PM

    You are welcome and as mentioned, do let us know in case there are any issues and we would be happy to look into it.