My form does not submit - it gets stuck on "Please wait" after clicking submit

  • Profile Image
    SRWproducts
    Asked on March 10, 2015 at 11:12 AM

    I've filled out my form and tried to submit it and other people have tried too on their computers and it just sits there and says Please Wait.

  • Profile Image
    Carina
    Answered on March 10, 2015 at 01:43 PM

    I tested and could replicate the same situation:

     

    I created a clone and made further tests and it seems that the form collapses created this difficulty. 

    You can test the demo form:

    http://form.jotformpro.com/form/50685281810960?

    Let us know if we can assist you further.

  • Profile Image
    SRWproducts
    Answered on March 10, 2015 at 01:45 PM

    It was working fine up until today. The collapses have always been in there and we still want them. Nothing has been changed on our end from yesterday to today. Why does it not work now?

  • Profile Image
    Carina
    Answered on March 10, 2015 at 03:20 PM

    I added the form collapses again and the problem persists:

    http://form.jotformpro.com/form/50685281810960 

    I forwarded this situation to our developers so they can analyse better this situation. They will contact you via this thread once they have an update on this situation.

    Let us know if we can assist you further.

     

  • Profile Image
    SRWproducts
    Answered on March 12, 2015 at 02:49 PM

    Any updates from the developers? I did delete my collapsable areas.  I would like to have them back if possible since they were working up until now.

  • Profile Image
    Ben
    Answered on March 12, 2015 at 04:14 PM

    Our developers are working on this.

    Could you however please try the clone of my colleague: http://form.jotformpro.com/form/50685281810960 to see if the same issue is still present for you?

    If not, feel free to add the Form Collapse buttons back to your jotform and let us know how it goes.

  • Profile Image
    SRWproducts
    Answered on March 12, 2015 at 04:37 PM

    It is still present in your clone. And I cannot find the Form Collapse widgets anymore to add them back.

  • Profile Image
    jonathan
    Answered on March 12, 2015 at 05:54 PM

    The reported issue is still open and currently assigned to one of our developer.

    They will post response here when available.

    For the meantime, I also checked and test your jotform http://www.jotform.us/form/50265342924150, BUT I could not reproduced the non-submission of the form issue.

     

    it went to the Thank You Page immediately after hitting Submit button.

     

    It seems the difference on your form now is, it only contains 1 collapse field on the bottom as opposed to the previous version where it has a lot of collapse field. 

    Did you removed the collapse fields?

     

     And I cannot find the Form Collapse widgets anymore to add them back.

    I am not sure how you meant here. The collapse field is found in the Survey Tools in the Form Builder. Click and Drag to add it on the form.

     

    Please let us know if the issue still remains.

    Thanks.

     

     

     

     

  • Profile Image
    wegoshop
    Answered on March 13, 2015 at 04:23 AM

    See if you have any spacer widgets. They updated the widget, without telling anyone or testing obviously and they caused problems. They said I could put them back and it should work but I just deleted them. Jot forms are starting to become crap. You pay for something, get it working just right and bam  YOU LOSE INCOME because something broke on their end and you had no idea. Sorry, can you tell I am irritated? Good luck.

     

  • Profile Image
    SRWproducts
    Answered on March 13, 2015 at 08:47 AM

    I deleted them because they were causing the issue. I have a clone of my form that they are still in and the submit button does not work.

    The clone with collapse is here: http://form.jotform.us/form/50705364907154

    We would really like the form to work WITH all of the collapses.

  • Profile Image
    Carina
    Answered on March 13, 2015 at 10:34 AM

    @Wegoshop

    Thank you for your input. I am very sorry about your situation but this seems a different situation as I could not detect a spacer widget and the form works perfectly as soon as we remove the form collapses.

    I kindly ask you to open a new thread with details on the forms where you have experienced that situation so it can be addressed by our team. 

    @SRWproducts

    Please accept our apologies for this situation. This ticket was already assigned to a developer and has a high priority status. We'll contact you via this thread once we have an update on this situation. 

    Let us know if we can assist you further.