What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Have not received Sub-User Account invitation link

    Asked by MLBtest on March 13, 2015 at 03:43 PM

    Good Afternoon, I've tried adding a sub account for a new user and he never got the e-mail invitation to see my shared forms. I have him clearing his caches and browser history. What do we need to do in order for him to see the shared forms? Thanks!

     



    This is a re-post of a comment on How to share forms with a sub-account user

    sub account sub user
  • Profile Image
    JotForm Support

    Answered by Mike on March 13, 2015 at 05:50 PM

    Thank you for contacting us.

    He will basically need to register a new account with email address listed under your Sub-User Accounts.

    https://www.jotform.com/signup

    We can also try to check our email logs, but we will need the email address in question.

  • Profile Image

    Answered by MLBtest on March 16, 2015 at 10:17 AM

    He advised that he has already created an account. He tried to view the shared forms and they are not there.  I've deleted his sub user account and added him again.  He still can't see them.

    His e-mail address is Vincent.Lenguyen@la.gov

     

  • Profile Image

    Answered by Sean on March 16, 2015 at 11:25 AM

    I checked the account associated with that email - vincent.lenguyen@la.gov/vlenguyen - and I was able to see your shared folder.



    Please advise him to clear his browser cache or try another browser and this should resolve this issue. Do let us know if the issue persist.


    Cheers!