Submit Button Disappears in Firefox 7.0.1 on Windows

  • Profile Image
    simonglenister
    Asked on October 31, 2011 at 07:35 AM

    I have a form which has been displaying perfectly on all browsers on both Mac and PC, however all of a sudden, the Submit button won't display when viewed in Firefox 7.0.1 on the PC. The Submit button displays on all other browsers using Safari, Chrome and Internet Explorer on both Mac and PC, including Firefox 7.0.1 on the Mac.

    The form has some conditional formatting in Question 1 and Question 11. If I enter '0' (zero), for Question 1, Questions 2 to 10 are hidden and then the submit button displays correctly, likewise, if I enter 'Never' for Question 11, Questions 12 to 20 are hidden and the Submit button then displays.

    This problem has only just started happening. I'm unsure if it is realted to an update to Firefox or if it is related to something else?

    Can anyone suggest anything to try to overcome this problem?

    Many Thanks

  • Profile Image
    idarktech
    Answered on October 31, 2011 at 08:37 AM

    Hi Simon,

    Thank you for your concern, I have tested your form on the exact version you have which is Firefox 7.0.1 and running on Windows OS but didn't replicate the issue, can you please reset your browser settings and clear your browser cache? Check my screen below:

     

    Please do let us know if the problem still persist so we can assist you with this. Thank you!

    ~idarktech

  • Profile Image
    simonglenister
    Answered on October 31, 2011 at 08:58 AM

    Hi idarktech

    The problem only occurs when there is no entry for Question 1 or 11. When you first load the form for example, before completing any of the questions...

    As soon as you put zero for Question 1, the Submit button appears and the same for Question 11, as soon as you select 'Never' the Submit button appears, but before that ,this is where my problem lies.

    Could you let me know if when loading the form before making any entires, you can still see the Submit button at teh end of the form.

    Many thanks

  • Profile Image
    liyam
    Answered on October 31, 2011 at 10:42 AM

    Hello,

    I can't seem to replicate your problem.  I'm also using Firefox 7.0.1.  Have you tried what idarktech suggested (clearing your browser's cache)?  If possible, can you also tell us the URL where this form is embedded (if you're experiencing this on some webpage outside JotForm)?

    Thanks.

  • Profile Image
    simonglenister
    Answered on October 31, 2011 at 10:48 AM

    Hi

    Yes, I had already tried clearing the browser's cache, to no avail (sorry I should have mentioned that)...

    This the url http://www.visionecreativa.co.uk/meetingroomsunlimited/Survey.html

    I'd be interested to see if you can see the Submit button when this page is first loaded, to rule in or out a problem on my PC...

    Thanks

  • Profile Image
    liyam
    Answered on October 31, 2011 at 11:29 AM

    I have checked your page and what I found is that the div height where your form is embedded seems to be restricted.

    You can search for this tag in your page:

    <div class="com-apple-iweb-widget-HTMLRegion" id="widget0" style="height: 4951px; left: 450px; opacity: 1.00; position: absolute; top: -2px; width: 700px; z-index: 1; ">

    As you can see, the height of the div that encloses the widget is set to 4951px.  Your form's actual height is 5107px.  So I would suggest for you to change the style height of this tag to 5107px at least.

    Please let us know after you've made the change.

  • Profile Image
    simonglenister
    Answered on October 31, 2011 at 11:47 AM

    I've been in and manually changed the height of the div to 5107px, even though if I select the form, it is telling me it's height is 4951px, but this makes no difference.

    What makes no sense is that the Submit displays in every other browser correctly, even with the height div set at 4951px, it even displays in Firefox 7.0.1 on the Mac, and up until very recently, it dispalyed correctly in the PC version of Firefox as well.

    Totally baffled as to what is cuasing this problem...

  • Profile Image
    liyam
    Answered on October 31, 2011 at 12:32 PM

    In addition to the change made in the div, search for this other div just below the one you have edited:

    <div style="height: 4985px; line-height: 4985px; " class="spacer">&nbsp;</div>

    then change this to:

    <div style="height: 5120px; line-height: 4985px; " class="spacer">&nbsp;</div>

    I also recommend for you to change the 1st div I asked for you to edit to 5120px to give an allowance just in case.

  • Profile Image
    simonglenister
    Answered on October 31, 2011 at 12:34 PM

    As a test, I've kept everything the same but simply added an additional 'field' below the Submit button. The result of this is that the Submit button now shows, but the additional Field below the Submit button is 'cropped', you can just see the top of the text.

    The problem only exists on Firefox for the PC, everything is still displaying correctly on every other browser...

    The old form size was 4951px, with the additional field it is 5030px...

    Baffled?

  • Profile Image
    simonglenister
    Answered on October 31, 2011 at 12:43 PM

    Ok, this appears to fix the problem, however I'm using the code generated by JotForm to embed into an iWeb HTML widget, does this mean that there is a slight problem with the code that JotForm is generating or is it more likely a bug in iWeb?

    The only way I can make the change is to manually edit the html to extend the two divs?

  • Profile Image
    liyam
    Answered on October 31, 2011 at 12:57 PM

    The form generated by JotForm does not seem to be the issue as it's just some basic coding tags. Probably it's with the declaration of the height that actually caused this.  You can try removing these height declarations and see if it will automatically adjust automatically (unless this is required by your web page layout / template).