What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    "N/A" sent to Zapier instead of submitted data for checkbox field - others are sent properly

    Asked by Princesscapades on March 23, 2015 at 11:29 AM

    I am using a program called Zapier to get my Jotform submissions to automatically populate as an event on my Google calendar. It worked splendidly for months, but now one category keeps coming up as N/A. I contacted Zapier about it but they said the info coming into Zapier was N/A so the problem was not on their end. 

    Similar fields work just fine, it is just the "Pick Your Princess" field that pops up N/A. I've deleted and re-added the field in question and it still does not work. I also deleted and readded the zap on Zapier to no avail. 

    Anything else I can try? 

    Thanks!

    Page URL:
    http://www.chicagoprincessparties.com/#!party/c1wm5

    Screenshot
    JotForm Submissions Google Calendar Zapier
  • Profile Image

    Answered by Ben on March 23, 2015 at 01:11 PM

    Could you please take a screenshot of the Zap setup for this field?

    Looking at the form I do not see any reason that would cause this, but just in case, I went ahead and cleared your jotform cache, so please do make a test to see if the issue is still happening.

  • Profile Image

    Answered by Princesscapades on March 23, 2015 at 03:28 PM

    Just tested it and it didn't work. Here is a screenshot of the zap I made on Zapier: http://i.imgur.com/7RDQJgQ.png

    The fields "Pick your pirate" and "Pick your prince" and "Pick your superhero" all work just fine! It's only the princess one. So weird.

    Thanks for your help! 

     

     

  • Profile Image

    Answered by Ben on March 23, 2015 at 05:15 PM

    I have cleared them once again, but since you say that it did not work, I am not sure that it would help, but do feel free to test.

    In the mean time I am raising this to our developers to inspect what might be going on with this so that they can check and see what could be the cause of that.

  • Profile Image

    Answered by Princesscapades on March 24, 2015 at 02:47 PM

    Hey I am not sure what you did, but it seems to be working again! Just had a couple of requests go through and the princess field popped up like it should!

    What was the issue? Anything I should do different in the future to prevent this or was is just a bug?

    Thanks so much! 

  • Profile Image

    Answered by Princesscapades on March 24, 2015 at 03:45 PM

    Also, there seems to be a comma and a space between each princess which is amazing and something I have been dying for! How did you do that?!

  • Profile Image

    Answered by Ben on March 24, 2015 at 04:54 PM

    I presume that the issue was resolved from Zapier's side since otherwise a developer would have made an update here about it.

    From what I know is that all data sent from us to Zapier is an array, so everything is separated in special layout that allows easy handling and Zapier is the one that will turn it into comma separated or space separated, etc string.

    I am however glad that it is working for you and I will be closing the ticket on our side - since our developers have probably contacted them about this when I raised the thread.

    Do let us know however if you have any issues or questions along the way and we would be happy to assist.