Atachement Limits Not Working

  • Profile Image
    bigpicturecomp
    Asked on March 24, 2015 at 09:29 PM

    I have several forms that allow visitors to send me images using the attachment feature. I have it set to limit the size to 10MB and the number of images to 3.

     

    If someone attaches 3 images, deletes them attaches 3 more and then sends me the form... I get six images. Advice?

  • Profile Image
    EltonCris
    Answered on March 25, 2015 at 05:15 AM

    Hi,

    May we know if you were you able to reproduce the problem? I have tried your steps but I can't reproduce it here. I tried uploading 3 files, deleted it and uploaded more files but I am always prompted with the limit error.

    I also can't reproduce the problem on my test form with the same limit imposed.

    http://form.jotformpro.com/form/50832557461962? 

    Do you have any other exact steps on how to reproduce the problem? If you have also embedded your form, let us know the website URL so we can submit a test.

    We'll await your reply. Thanks!

  • Profile Image
    bigpicturecomp
    Answered on March 25, 2015 at 01:38 PM

    Yes, this has been repeatable.

    You attach 3 images. Delete all 3 images. Then attach 3 more as replacements. Pay. I receive 6 images.

  • Profile Image
    david
    Answered on March 25, 2015 at 02:55 PM

    I cloned your form to test it and I only receive the attached images no matter how many times I added and removed them:

    Try removing the current file upload field and replacing it.  If that still does not allow for the files removed from the field to be removed from the submission, let us know and we will be happy to have another look.  As far as I can tell though, deleted files from the field are not included.

  • Profile Image
    bigpicturecomp
    Answered on March 25, 2015 at 03:33 PM

    So I'm lying then?

  • Profile Image
    BJoanna
    Answered on March 25, 2015 at 05:10 PM

    We do not think that you are lying. We just can not reproduce problem you noticed on our end. I cloned your form and tested it one more time and I got the same result like my colleagues. I uploaded three images, deleted them and uploaded three new different images again. I got submission with only three images I submitted.

    Did you try suggestion that my colleague provided you? Try removing the current file upload field and replacing it.  If that still does not allow for the files removed from the field to be removed from the submission, let us know and we will be happy to have another look.  As far as I can tell though, deleted files from the field are not included.

    You can also try to clear your Form Cache.

    Hope this will help.