Required fields not working properly

  • Profile Image
    Swoodruff2002
    Asked on April 01, 2015 at 01:50 AM

    I have file uploads as required fields in an embedded form. When I test without completing the required fields, the "go back" link does not resolve.  

    Please see this link and test SUBMITT without required file uploads.

    http://harvestinghappinesstalkradio.com/be-a-radioshow-guest/

     

    Here's what I get when it fails:

    http://screencast.com/t/TjBkggUWj

    Thanks,

     

    Steve 

    818.455-7452

    swoodruff2002@gmail.com

     

     

  • Profile Image
    cyberhopper
    Answered on April 01, 2015 at 02:05 AM

    Hi Swoodruff2002,

    Ive tested the form submission on my side using Firefox (37.0) browser, the form goes to the incomplete values notification page as per your screenshot with the URL being javascript:window.history.back(-1)

    On clicking the  back button the form is reloaded with the previously submitted data. which browser were you using that caused the link not to resolve? this information will be helpful in troubleshooting the unexpected behavior.

  • Profile Image
    Jan
    Answered on April 01, 2015 at 10:34 AM

    Hi swoodruff2002,

    When you try to fill up the direct or stand alone form, it should look like this if you hit submit without completing the required fields.

    Since the form is embedded to you webpage, there is a possibility that it is having a conflict between the scripts.

    Please try to re-embed the form using the iFrame method to avoid conflicts between your webpage scripts and JotForm scripts.

     

    Hope this works. Let us know if you need any help.

    Thank you.