Form Collapse: Not working on first load - needs refresh

  • Profile Image
    mdmclean88
    Asked on April 01, 2015 at 11:11 PM

    Hi Team,

    I am really happy with Jotform and all the options available. One thing that affects my usability of it is that when I embed the form in my responsive website, it has an issue.

    I have multiple collapsible sections on my form that begin as closed to help reduce the info overload on form fillers. I am having an issue where if the page loads, the form collapsibles are not clickable unless the page is refreshed. Any ideas for something I may be doing wrong?

    Thanks a lot for your assistance. 

    The form can be found here:

    www.awhistleandalight.com/tellyourstory

     

    Matt

  • Profile Image
    Jan
    Answered on April 02, 2015 at 09:51 AM

    Hello there,

    We're glad to hear that you are happy with our services. I checked your webpage and I saw the problem, you are right regarding the form collapse is not working properly.

    It is possible that there is a conflict of scripts between JotForm and your webpage. Please try to re-embed the form using the iFrame method.

    Hope this works. Let us know if the issue is still the same.

    Thank you.

  • Profile Image
    mdmclean88
    Answered on April 02, 2015 at 01:20 PM

    Hi Jan,

    I just tried something. I had a random condition that was still active for my form. I deleted that condition and then just tried my form again and it didn't have the issue. 

    Can you please confirm for me that it is now working on your end as well?

    Thanks for your suggestion, unfortunately as my site is responsive, an iframe is not ideal and with the dropdowns, I fear that an iframe will not react the way I prefer. I understand I am limited in what is possible but yes if the script can work as intended then I am hoping the fix I have made will fix the problem?

    In any case, I think it is fixed? If you can confirm that you see the problem has stopped on your end, that would be great?! 

    Thanks a lot!

    Matt

  • Profile Image
    Mike
    Answered on April 02, 2015 at 04:02 PM

    The form seems to be fine in Safari and Firefox, but I was able to reproduce the issue in Google Chrome and Internet Explorer. The issue might be related to javascript processing which is different across the internet browsers. I have attached a bug report ticket, but there is no ETA at this time. We will let you know if we have any updates.

    The iFrame should be responsive in terms of width, and for the height you might try a scrolling="auto" parameter.

  • Profile Image
    Mike
    Answered on April 02, 2015 at 07:24 PM

    Our developers have added a little update, so the issue seems to be fixed. Please clear your browser cache and re-check the form.

    Thank you.

  • Profile Image
    Matt 
    Answered on April 04, 2015 at 03:38 AM

    Hi Mike and Jan,

    It is now working as expected. Thanks a lot for getting on this so quickly! I appreciate it and look forward to continuing to use Jotform!

     

    Have a great day!

  • Profile Image
    Welvin
    Answered on April 04, 2015 at 09:22 AM

    Hi Matt,

    Thank you for updating us here. Please contact us again if there are any problems.

    Have a great day!