JS Embed form on ipad not advancing when clicking next

  • Profile Image
    thedeltadentist
    Asked on April 02, 2015 at 01:56 PM

    hi-we use our jot form form on an ipad and for 2 days, the next button at the bottom of the page does nothing so our patients can't advance thru the form.  

    we go to safari, thedeltadentist.com, patient forms, click the link all on the ipad.  it works fine on a computer.

    this is our patient registration and medical history.

    please help us get the functionality back.

     

    thanks, dr. lisa friberg

  • Profile Image
    Mike
    Answered on April 02, 2015 at 04:47 PM

    Thank you for contacting us.

    It appears that some JS embedded forms are not currently processed correctly on the first load. We have escalated the issue to our Development Team in order to investigate this further.

    In the meantime, please try switching to the iFrame form code:

    Getting the Form iFrame Code

    It should fix the issue.

  • Profile Image
    Mike
    Answered on April 02, 2015 at 07:28 PM

    We have added an update to the system, so the issue should be fixed.

    Please let us know if you notice the issue once again. Thank you.

  • Profile Image
    lisa friberg 
    Answered on April 04, 2015 at 01:57 PM

    hi-appreciate the help, however, the NEXT button still does not advance the form on the ipad.  do you have any other ideas?

    thanks, lisa

  • Profile Image
    raul
    Answered on April 04, 2015 at 05:49 PM

    Does this also happen when you access the form using its direct URL: https://secure.jotform.us/form/43436542735154? Also, can you please try using the iframe embed method in your webpage as previously suggested?

    Let us know if this makes any difference or the issue persists.

  • Profile Image
    lisa friberg 
    Answered on April 04, 2015 at 06:55 PM

    when i type the URL in the ipad mini, it works.  the bar at the top looks different when i type URL and when i go to the website...see screenshots..

  • Profile Image
    jonathan
    Answered on April 04, 2015 at 08:31 PM

    I think the issue is being caused by script conflict since the form on the website was embedded using the script embed code

     

    as previously suggested, can you please re-embed the form on the website BUT use its iframe embed code instead.

    Follow the user guide: -Getting-the-Form-iFrame-Code

     

    Make sure to clear first any previous existing script code of the form before re-embedding using the iframe code.

    Inform us if issue is still not resolved.

    Thanks.

     

     

  • Profile Image
    thedeltadentist
    Answered on April 04, 2015 at 09:41 PM

    great..will give it a try.  just curious why it would have worked for 3 months as it was and then stop?  

  • Profile Image
    Welvin
    Answered on April 05, 2015 at 09:05 AM

    Hi,

    Well, I think that is because of the codes being used in the form as well as to your website. The sources (from your website and the form) may have been updated to the other versions causing it to create a conflict in your website. I think we also need to consider the browser updates.

    As suggested, please give the iFrame a try and update us here if the issue persists.

    Thank you!