Calculation answer/output sometimes shows 0

  • Profile Image
    dhoeke
    Asked on April 02, 2015 at 04:18 PM

    Hi,

    On my site I have several calculations that can be filled out in order to get a result. This is made for teachers.

    Now sometimes when you open the pages or variants (like 80%/70% etc) the lower outcome shows a 0(zero) by default and then it does not do the calculation. Other times there is no 0(zer0) in the outcome field and then it works as I should i.e. filling in the blanks and seeing the answer. Why do I sometimes get this 0(zero)?

    Thanks for your help.

  • Profile Image
    raul
    Answered on April 02, 2015 at 06:45 PM

    Can you please provide more information about how can we reproduce the issue? Does this also happen when you view the forms using its direct URL?

    I've checked some of the forms on your site but I couldn't see any errors in them.

    Can you also explain a little bit the formula you use to calculate the values?

    I think there might be a glitch when "Te behalen totaal aantal punten" is zero because if you divide a number by zero it would give an error. But I would like to know better the formula you're using to see how can we make sure this error doesn't happen.

    We'll wait for your response.
    Thank you.

  • Profile Image
    dhoeke
    Answered on April 03, 2015 at 02:56 AM

     Hi,

     

    Thank you very much for the reply. It looks like after updating Joomla (to 3.4.1), the problem is gone..

    So it might be that it had to do with that. Before I had no problems as well, so maybe it was a Joomla glitch. Thanks again for the effort. 

  • Profile Image
    Jan
    Answered on April 03, 2015 at 05:56 AM

    We're glad to hear that your issue is resolved now. Thank you for letting us know. On behalf of raul, you're welcome.

    Let us know if you need any help.