What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    FormsCentral Import Tool: Downloaded fillable PDF form edited it and re-imported it but have not yet received in JotForm account

    Asked by dezertguy on April 03, 2015 at 11:00 AM
    I "fixed" my original form on the computer, deleted the former one from my list on JF and uploaded the revised version.  I did this three days ago and my new upload still does not appear in my list.  Did you receive it?  Thank you.
    import pdf pdf import form
  • Profile Image
    JotForm Support

    Answered by Charlie on April 03, 2015 at 11:14 AM

    Hi,

    The import tool for fillable PDF form may take a couple of days as this is quite a new feature in our Import Tool. Could you share us the name of the PDF file that you imported? That would help us track where it is.

    However, I'll escalate this to our back end team so that they can check if there's any import status of your PDF form.

    We'll let you know on this thread when we hear any news.

    Kind regards.

  • Profile Image

    Answered by dezertguy on April 03, 2015 at 04:11 PM

    I wasn't sure about the timing.  I submitted a form immediately after you started offering this service and it did take three days.  I uploaded a second form and ... boom ... it was there in minutes.  This is no big deal, I was just curious.  The file uploaded is Employment App Form NEW.  That is the only one I've uploaded recently.  Have a good one.

  • Profile Image
    JotForm Support

    Answered by jonathan on April 03, 2015 at 05:41 PM

    I also confirm that it should be uploaded immediately by now. I was able to experienced this when I was testing the Upload PDF Form feature in JotForm.

    Can you please try using this link instead to upload your PDF Form to your account.

    http://www.jotform.com/adobe-formscentral-alternative/

    #1 Click on IMPORT FORMS button

    #2 Select PDF Only Upload option

    #3 Upload the PDF Form/file from your computer and click on Submit.

    Make sure you indicate your correct JotForm email account in the email address box. This will ensure that the uploaded PDF will go to your account My Forms page.

     

     

    when successful, you will immediately received notification email about it. 

    Like this...

     

    Hope this help. Let us know how it goes.

    Thanks.

     

     

  • Profile Image

    Answered by dezertguy on April 03, 2015 at 07:06 PM

    Just tried it; was up there in seconds.  I downloaded it and the submit button was present.  I completed a test, submitted it and downloaded an Excel of it.  All of the process went smoothly, but the form does not contain the check box fields.  The remaining fields are present, but no check boxes.  Progress is happening.  Thanks.
  • Profile Image

    Answered by raul on April 03, 2015 at 08:53 PM

    It seems like the original issue has been solved when you tried to import the PDF form again, right? And now you're having a different issue which is that checkbox fields are not appearing in the submissions.

    Can you please confirm? So we can update the raised ticket and troubleshoot the new issue.

    Thank you.

  • Profile Image

    Answered by dezertguy   on April 03, 2015 at 10:16 PM

    Yep, that's the current issue. 

  • Profile Image

    Answered by raul on April 03, 2015 at 10:20 PM

    Thank you for confirming.

    I've moved this new issue report to a separate thread so we can properly address it.
    You can find this thread here: http://www.jotform.com/answers/546327

    We'll be answering shortly.