Issue Date "Submission Date" spreadsheet in Google showing as 1/1/1970

  • Profile Image
    mesadeayudait
    Asked on April 08, 2015 at 01:53 PM

    Currently soon as a record is entered in the form. This is stored in a spreadsheet on Google, but the information Submission Date field is coming evil.

    For example, a record is saved as 1/1/1970 3/31/2015. The year is wrong because it is 2015 and not 1970

    This happens with two different forms

    urgent

    Thank You

  • Profile Image
    david
    Answered on April 08, 2015 at 03:32 PM

    Hi,

    We are currently experiencing some issues with our Google Spreadsheet integration.  I have forwarded the information you provided to our development team to have a look.  We will update you here as soon as we have any further information.  Our apologies for any inconvenience this has caused.

  • Profile Image
    mesadeayudait
    Answered on April 08, 2015 at 05:18 PM

    I am very aware of the aid.

     

    It is a very urgent issue

     

    Thank You

  • Profile Image
    jonathan
    Answered on April 08, 2015 at 07:04 PM

    We will let you know here as soon as our dev have update on the status of the bug ticket submitted.

    Thank you.

  • Profile Image
    Jeanette
    Answered on April 09, 2015 at 02:58 PM

    This problem has been resolved. We appreciate your patience.

  • Profile Image
    Jeanette
    Answered on April 09, 2015 at 02:59 PM

    Please disregard the previous note, the problem with google integration was solved, the one related to date is still being looked into.

  • Profile Image
    mesadeayudait
    Answered on April 09, 2015 at 04:01 PM

    Hello

     

    Do not you know you're doing, but it turns out that today neither are saving the new records. They get mails with notification but not stored in spreadsheets from Google Drive.

     

    Please attend to the urgency.

  • Profile Image
    Jeanette
    Answered on April 09, 2015 at 05:26 PM

    I just made a test and it works.

    Please remove and rebuild the integration in order to make it to work again.

  • Profile Image
    alp_deniz
    Answered on April 09, 2015 at 08:03 PM

    Hello, 

    Could you please let us know if the problem is resolved after re-integration? A new fix has been made some hours earlier.

    Kind regards

  • Profile Image
    Jose 
    Answered on April 13, 2015 at 07:47 AM

    Also could you please inform what files we need to update to get this fixed ?

    Thanks for your help!

  • Profile Image
    david
    Answered on April 13, 2015 at 10:59 AM

    Hi,

    You should not have to update anything other than redoing your integration.  The issue was on our end and has since been resolved. 

    http://www.jotform.com/help/228-How-to-Integrate-Form-with-Google-Spreadsheet

    If you still have any issues with your integration after setting it up again, let us know and we will be happy to have another look.

  • Profile Image
    chantinon
    Answered on April 23, 2015 at 08:36 PM

    several times, and the error happens again when you insert new data to prefill form, or insert data directly in the spreadsheet. 
    I need the old data into the new integration, how do?

  • Profile Image
    Jeanette
    Answered on April 23, 2015 at 10:29 PM

    Unfortunately the new integration created a new spreadsheet. You might need to manually copy and paste from one sheet to another in order to get all together.

  • Profile Image
    mesadeayudait
    Answered on April 24, 2015 at 09:39 AM

    We made new integration to solve the problem, because it is present again. But today again this date appearing wrong, please help urgent

     

    thanks

  • Profile Image
    raul
    Answered on April 24, 2015 at 11:55 AM

    I've made a test using a cloned version of your form and was unable to reproduce the issue.

    Do you have any custom date formatting enabled on the sheet? Or do you use another application to work with it? Can you also try to create a cloned version of your form and create the integration in it to check if the same issue happens?

  • Profile Image
    alp_deniz
    Answered on April 25, 2015 at 01:43 PM

    Hello,

    The problem is most probably caused by setting "Locale" for your sheet or by an app that re-formats the sheet for "Spanish". It will work as expected if you re-integrate and do not set a "locale" or an app that formats the sheet.

    We will be following up. Please let us know the status.

    Kind regards

  • Profile Image
    IvoHuurdeman
    Answered on April 26, 2015 at 08:59 AM

    I've been experiencing the exact same problem. However it's not just the submission date column that gives the "1-1-1970 0:00:00" value. Each column that contains a date gets this value. I really hope that this issue can be fixed because otherwise I really can no longer use the submissions I receive via Jotform forms.

     

    Kind regards  

  • Profile Image
    IvoHuurdeman
    Answered on April 26, 2015 at 09:54 AM

    The problem occurs each time a new entry is done. All the date fields of the new entry are shown like "1-1-1970 0:00:00". If I then break the integration and create it again all entries are shown correctly (so also the last entry). However once a new entry is done the dates for this entry will be shown incorrectly. So rebuilding the integration has the effect that all the former entries are being shown correctly but it doesn't solve the problem that each new entry (after the rebuilding of the integration) will be shown incorrectly.

     

    Kind regards,

     

    ivo 

  • Profile Image
    raul
    Answered on April 26, 2015 at 11:28 AM

    @IvoHuurdeman

    I've moved your inquiry to a separate thread in order to properly address it.
    You can find it here: http://www.jotform.com/answers/559245