What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Integration with Salesforce sets up once ok and then the first form submission fails with invalid password. How to fix this?

    Asked by arthesis on April 08, 2015 at 01:55 PM

    I have Salesforce production account with the API enabled. I can log in the developer portal of Salesforce. I try to set up integration with it for one of my forms. It accepts the credentials and all is successful - the interface says connected. Salesforce's login history also shows success. Then I try other actions like a form submit or edit on the form integration settings and I get an invalid password error. What can I do to fix that?

    Page URL:
    http://form.jotformpro.com/form/50852806608964

    invalid password settings salesforce integration
  • Profile Image
    JotForm Support

    Answered by BJoanna on April 08, 2015 at 03:54 PM

    I cloned your form and I successfully connected my cloned form on Salesforce. After submitting form I successfully got mapped information inside of Salesforce.

    After submitting form I got information inside of Salesforce.

    Could you please try reintegrating Salesforce? Do you use correct token? 

    In case that you can not resolve problem with reintegration please could you provide us screenshot of error that you are getting to have a closer look on it.

    Looking forward to your reply. 

  • Profile Image

    Answered by arthesis on April 08, 2015 at 05:47 PM

    I still have the problem. I tried reintegration, issuing new security token, new form, binding leads, contacts, accounts. it is all the same. Here are the screenshots:

    Starting fresh

    Then entering my credentials

    I then choose leads

    Then associating fields with the CRM ones. I choose name to be company name as i dont have it in the form. I tried a new form that had it with the same issue.

    It seems ok after pressing finish

    Then i go on and submit the form

    and then i got nothing in leads in the CRM...

    The log shows

    and when I try to modify the config of the integration in JotForm I see this

  • Profile Image
    JotForm Support

    Answered by BDAVID on April 08, 2015 at 07:51 PM

    Can you please try clearing your forms cache and reintegrating with Salesforce using new security token, let us know what happens.

  • Profile Image

    Answered by arthesis on April 09, 2015 at 02:36 AM

    Unfortunately that also did not work. There is no change. Any other ideas? 

  • Profile Image

    Answered by Ben on April 09, 2015 at 10:41 AM

    Please try to not map the fields two times as above - Name* Name*.

    Instead just skip the one field that you do not have the corresponding field to map to.

    If that does not help by some chance, do contact SalesForce, to see if there is any reason why your account would not be able to be connected to their service:

    "Invalid username, password, security token; or user locked out"

    - I am talking here about the "user locked out" part.

    Do let us know how it goes.

  • Profile Image

    Answered by arthesis on April 09, 2015 at 11:00 AM

    I have tried that already - adding a contact instead of a lead does not require company so i map only fields that are distinct and non repeating. Same error. 

    The user is most definitely not locked out. I am able to use the Salesforce account alright, and also when I reenter the credentials during reintegration the status is connected.

    It seems to me the password and token are not stored properly. Do you have restrictions on the password symbols?

     

  • Profile Image

    Answered by arthesis on April 09, 2015 at 11:07 AM

    Yes! I was right!........ My password was too complex! I changed my Salesforce password to something that has only letters and numbers and now the integration works. I'd appreciate it if you log a bug and let me know when its fixed.

  • Profile Image

    Answered by Shadae on April 09, 2015 at 12:24 PM

    Hi arthesis,

    Thank you for providing us with this information. We are happy to hear that your integration is now working correctly.

    I have submitted this bug to our second level support team. Once there is an update on the issue it will be posted to this thread.

    Thank you.