What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Submissions Excel: In Excel collumns are not holding correct values, while opening in Google SpreadSheet displays OK

    Asked by andyohara on April 13, 2015 at 06:40 AM

    Hi,

    I've not checked the Excel submissions for one of my reports (for http://www.jotformeu.com/form/50684865684370) in a week or so. When I looked today, I noticed that some of the formulas I had created which I add onto the submission reports were returning incorrect data. Looking closely, it appears that some of the information is pulling through into the wrong field - e.g. something that should be appearing in M3 is appearing in N3. 

     

    Upon consulting with one of my colleagues, she suggested I try viewing the data in Google Docs - when doing this, the report appears correctly, with everything in the right place as far as I can see. I would much prefer to get the Excel version working again though, as all the formulas I've designed work well in that and may not copy over to Google Docs without some work. 

     

    I haven't made any changes to the form since I made the link available to my users, which is why it is puzzling that this has happened. 

    Page URL:
    http://www.jotformeu.com/form/50684865684370

    Screenshot
    Submissions excel excel submissions Reports
  • Profile Image

    Answered by storagesquad on April 13, 2015 at 07:13 AM

    As of yesterday the exact same thing was happening to me as well.  HELP

  • Profile Image

    Answered by Ben on April 13, 2015 at 11:48 AM

    I would just like to confirm if this happens when you download the Excel from within the Submissions Panel, or if this happens to you when you download Excel Report?

    Based on your post, I believe that it is related to the file from withing Submissions Panel.

    No matter where it happens, did you try the other option?

    How to Export Form Data to Excel? (to download from within Submissions Panel)

    How to create an Excel Report? (to download Excel Report)

    Once you update us with this we will raise this to our developers for inspection with all the data included.

    @storagesquad I see that you already have 2 threads in regards to your issue:

    http://www.jotform.com/answers/550960

    http://www.jotform.com/answers/550953

    My advice would be to only reply on the first one above in order for our developers to be able to properly assist you and to have all data related to the issue in the same thread.

    Thank you.

  • Profile Image

    Answered by andyohara on April 13, 2015 at 12:23 PM

    Hi Ben, 

    Thanks for getting back to me. I was referring to this happening when I download Excel Report, however I've just tried the other way and the exact same issue is still occurring.

     

    Kind regards,

     

    Andy

  • Profile Image
    JotForm Support

    Answered by Charlie on April 13, 2015 at 02:27 PM

    Hi Andy,

    Thank you for updating us, we'll forward this additional information to our back end team together with the original report.

    This is now being handled by our back end team, we will update you as soon as we hear any news or if the problem has been fixed. 

    Again, apologies for the inconvenience.

  • Profile Image
    JotForm Support

    Answered by alp_deniz on April 13, 2015 at 07:24 PM

    Hello,

    The problem is resolved now. Thank you very much for letting us know.

    Kind regards

  • Profile Image

    Answered by andyohara on April 14, 2015 at 06:20 AM

    Thanks all for your support, it works perfectly now - though there are problems with other forms I hold, please see below post for details. 

     

  • Profile Image

    Answered by andyohara on April 14, 2015 at 06:33 AM

    Actually, although it works fine on this particular form, I have a couple of others that the same problem still exists on.

    This one: http://www.jotformpro.com/form/43103549519960

    And this one: http://www.jotformpro.com/form/42994204730960

    Kind regards,

    Andy

  • Profile Image
    JotForm Support

    Answered by Charlie on April 14, 2015 at 09:04 AM

    Hi Andy,

    Thank you for updating us, have you tried deleting the current excel report and creating it again? Please do clear your form's cache before doing this just to make sure. We'll wait for your response.

    Thanks

  • Profile Image

    Answered by andyohara on April 14, 2015 at 10:14 AM

    Hi Charlie,

    Thanks for the advice - clearing the cache and deleting the report to start again has worked fine in both these situations.

    Kind regards,

    Andy

  • Profile Image
    JotForm Support

    Answered by Charlie on April 14, 2015 at 11:20 AM

    You're most welcome Andy. I'm glad everything seems to be working good in your end now.

    If you needed any assistance again, please do not hesitate to open a new thread here in the forum.

    Thank you.