Incomplete Payments When Testing

  • Profile Image
    Alexpte
    Asked on November 07, 2011 at 04:22 PM

    I'm setting up a Paypal payment form but having trouble with incomplete payments. I'm using a family members Paypal account to complete the payments (I'm getting payment notifications and the user is getting a Paypal receipt) but they are still being marked as incomplete payments.

    Any idea why this might be happening?

    Thanks

  • Profile Image
    Mike_T
    Answered on November 07, 2011 at 07:27 PM

    Thank you for contacting us.

    Could you please confirm that the payments were done immediately after redirecting to PayPal site?

    We are looking forward to hearing from you.

  • Profile Image
    Alexpte
    Answered on November 08, 2011 at 04:01 AM

    Hi Mike,

    Yes the payments were all completed immediately after the form was submitted. After payment was completed I was redirected back to the thank you page that I had set.

  • Profile Image
    allanftd
    Answered on November 08, 2011 at 08:25 AM

    Hi Alexpte,

    I checked your Paypal - JotForm integration. Have you tried to setting the "Need payer address" to "YES"? Kindly try and see if it makes any difference in the results.

    We apolgoize for any inconvenience, please let us know if you need further assistance.

    Allan
    JOTFORM SUPPORT

     

  • Profile Image
    Alexpte
    Answered on November 08, 2011 at 09:19 AM

    Hi Allan,

    I change the "need payer address" setting to yes but it didn't make any difference. The payment still goes through but is marked in jotform is incomplete.

  • Profile Image
    fxr
    Answered on November 08, 2011 at 12:40 PM

    hi Alex,

    can you forward the paypal email receipt for the payment to jotformsupport (at) gmail (dot) com please?

    Mark the subject with this threads title, we will try to work out whats going on.

     

  • Profile Image
    Alexpte
    Answered on November 08, 2011 at 12:46 PM

    OK I just sent it, thanks for your help

  • Profile Image
    fxr
    Answered on November 08, 2011 at 06:48 PM

    Thanks for that.

    I couldn't quite tally up the email address up with one in your submissions, so did a test with my own paypal account just to be sure of the problem. 

    I see the same issue.

    I will submit a bug report to our developers, they should be able to get this cleared up for you.

     

     

  • Profile Image
    Alexpte
    Answered on November 09, 2011 at 08:02 AM

    OK, thanks for your help. Any ETA on when this might be fixed?

  • Profile Image
    fxr
    Answered on November 09, 2011 at 04:15 PM

    Without wanting to promise anything, it should hopefully be addressed before the weeks out. It obviously a significant issue and should be priortised. 

  • Profile Image
    aytekin
    Answered on November 10, 2011 at 02:19 AM

    Can you post screenshots of these pages on your PayPal account?

    Profile -> Instant Payment Notifications

    Profile -> Website Payment Preferences

  • Profile Image
    aytekin
    Answered on November 10, 2011 at 10:50 AM

    Update on this thread. The user has this on the PayPal IPN (Instant Payment Notifications) settings:

    IPN Message Delivery setting was disabled. Enabling it has resolved the issue.