What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Two forms are being displayed in our custom mobile app.

    Asked by virtualearth on April 14, 2015 at 12:14 PM

    Hi guys,

    The URL we are using (https://secure.jotformpro.com/form/51027081993961) is showing two forms in our application. On the web it is one form however for some reason which we haven't been able to find it is pulling two exact same forms.

    You can download the app on a mobile at: http://weddings.shareableapps.com

    In the hamburger menu go to Book a Consultation. The app is still in dev so it may load a little slow. Just close the app and reopen if it lags.

    Kind regards

     

    Brad

    mobile app two forms iPhone 6
  • Profile Image
    JotForm Support

    Answered by BJoanna on April 14, 2015 at 01:40 PM

    I have downloaded application on Android Samsung Galaxy S4 and after checking your form on option Book a Consultation I can see only one form. There are no two forms like you are mentioning. Considering this is mobile app we can not look inside of you code. 

    Can you please check one more time this?

    Maybe you can try with uninstalling application and installing it again. 

  • Profile Image

    Answered by virtualearth on April 14, 2015 at 05:47 PM

    Hi BJoana,

    We have tested on a range of phones and the problem of two forms loading is only happening on iPhone 6 8.3.

    Can you test at your end on a 6 please.

    Thank you

    Brad

     

    Wed April 15, 10am AU EST: We solved the issue for iOS with the latest update (8.3) however earlier versions won't work.

     

    Thanks for your help guys, really appreciated.

    Cheers

    BR

  • Profile Image
    JotForm Support

    Answered by jonathan on April 14, 2015 at 07:06 PM

    Hi Brad,

    I can only test your jotform https://secure.jotformpro.com/form/51027081993961 on an

    Iphone 6 Plus (iOS 8.0)  as I do not have the much higher OS version.

    I could not reproduced yet the issue of having 2 forms loaded on the browser as of this testing.

     

     

    Will you be able also to share to us a screenshot of the issue when it happens on your test form?

    If we can have a visual of the issue, it will help us understand more what to look for to troubleshoot the issue.

    Please let us know if issue is still not resolve.

    Thanks.

     

  • Profile Image

    Answered by virtualearth on April 14, 2015 at 08:06 PM

    Its ok, it is only happening in 8.3.

    We did a fix which likely now won't work on earlier versions of the iOS. For earlier version form loads however either won't load the whole form or the fields can't be completed within the application.

    This issue is not only related to Jotform, we have other client forms having a similar experience. Back to our dev for some more fixes.

    Thanks for all your help guys, appreciated.

    Cheers

    Brad

  • Profile Image

    Answered by Ben on April 15, 2015 at 09:51 AM

    In my colleagues' names you are welcome Brad.

    Based on what you have mentioned from the start, I could only suggest that your devs implement the form using the iframe method since there might be issues caused by conflicts if they used some other method.

    This would however be easier to debug if we were able to see the code itself.