What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Submission settings keep the default for cloned forms

    Asked by NMilligan on April 21, 2015 at 06:10 AM

    Hi

    We have created a form as a master copy which we then clone for specific forms.

     

    We set the submissions options on the master form options to auto hide empty fields & show headers & texts.

    When we clone the form it reverts to the following options checked auto hide empty fields and show addresses on map.

    We then have to remember to set these options every time we clone the form as it is part of our autoresponder to include the text parts in our pdf.

     

    So the question is can we either set these options as the default for all our forms and or can we set it so what we select will remain when we clone the form.

     

    Look forward to hearing from you

     

    Regards

     

    Nigel

    settings keep Submissions map hide empty fields checked
  • Profile Image
    JotForm Support

    Answered by ashwin_d on April 21, 2015 at 11:21 AM

    Hello Nigel,

    If I understand your question correctly, you are setting the "Auto Hide Empty Fields" & "Show Headers and Texts" from your form's submission page. Is that correct?

    Please be noted that when you clone a form, it only clones the form and its settings not the submission settings. That is the reason why the "Auto Hide Empty Fields" & "Show Headers and Texts" settings are not being cloned. Unfortunately there is no workaround available and you need to configure it manually.

    Let me send a feature request to our back end team. We will get back to you as soon as we have any update from them.

    Thank you!