Authorize.net Integration: Billing address not validated?

  • Profile Image
    dcboswell
    Asked on April 26, 2015 at 09:38 PM

    We are having an issue with improper data being entered into the state field of the Authorize.net integration. There is no validation so if they don't spell a state right or something there is nothing to prevent it from submitting the form.

    It would be ideal if there was a state drop down to prevent the wrong spelling / formatting. From what I've seen, there isn't a way to make adjustments to the form fields of the integration.

    I'm surprised Authorize.net would allow data that doesn't match the billing address.

    Please let me know what can be done to fix this.

    One last thing is if bad CC data goes in, it does throw an error but there is no way for the user to return to fix the information. So that
    is another thing that would be good to see fixed. Even if it was just a link back to the form that would be good.

    Thanks,

    Daniel Boswell

     

  • Profile Image
    Charlie
    Answered on April 27, 2015 at 03:36 AM

    Hi Daniel,

    Unfortunately, I believe the fields in the billing information are free text. This is because the billing address can be change other than what you have in your credit card. The only validation that the Authorize.net does is the credit card fields.

    For the state, it is not possible to have a drop down right now especially there are a lot of countries which would make the form load slower.

    But I could try escalate this to our back end team to see if they can do something about it, either in the form builder itself or a validation in the Authorize.net integration. Unfortunately, I cannot give an exact date to when this will be updated or if it will even be considered because this will depend on another team, but we'll update you as soon as we hear any news.

    Kind regards.

     

  • Profile Image
    Charlie
    Answered on April 27, 2015 at 03:40 AM

    For the other question regarding the error message not having a back link option, I've created a separate thread so that we can address it properly. Please refer to this link instead: http://www.jotform.com/answers/559481.