What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Google Drive and Dropbox: Uploaded files are not transferred when the save and continue method is used

    Asked by exchangepress on April 29, 2015 at 07:19 PM

    My Google Drive folder is not receiving uploaded files from the form.  The folder is created and the PDF summary is added to the folder, but the files uploaded by the user are not.  This is happening with two forms - one that was created several weeks ago (and was working fine yesterday) and a cloned version of that same form created today.  I tried removing the integration and adding it back in, but that did not work.

    The two surveys are:

    Original Form - http://form.jotform.us/form/50485747049161

    Cloned Form - http://form.jotform.us/form/51185595750159

    What happened?

    uploaded files receiving JotForm Cloned Form two forms
  • Profile Image
    JotForm Support

    Answered by jonathan on April 29, 2015 at 08:56 PM

    I just checked the Google Drive integration but I could not replicate the same issue you reported.

    But what I did noticed on your forms i.e http://www.jotform.us/form/50485747049161 is that none of the fields were set as *Required fields.

    The end-user can submit the form without answering anything on it (or not upload)

    Can you at least make a field mandatory to avoid user submitting an empty form.

    The submitted empty form will appear empty also in the Google drive account.

    Please redo also the integration process for the last time.

    Follow the user guide: -How-to-Integrate-a-Form-with-Google-Drive

     

    Let us know if the issue is not resolve.

    Thank you.

  • Profile Image

    Answered by exchangepress on April 30, 2015 at 12:04 PM

    The issue is not whether the field is required or not.  If you look at my account you will see that the files were uploaded to JotForm.  The issue is that they aren't being sent to Google Drive (or Dropbox I discovered this morning).  This form worked fine until yesterday.  I have removed the integrations for both Google Drive and Dropbox (more than once) and set them up again and it still doesn't work.  See the attached screenshot which shows the files in JotForm, the PDF summaries in Google Drive and Dropbox, and no uploaded files in either folder.

  • Profile Image
    JotForm Support

    Answered by KadeJM on April 30, 2015 at 01:15 PM

    Thank you for the clarification and further explanation of your issue with a screenshot you added. 

    Please allow me some time and I respond to you briefly after I investigate this issue furthermore.

  • Profile Image
    JotForm Support

    Answered by KadeJM on April 30, 2015 at 02:05 PM

    I believe your explanation at first lead my colleague Jonathan to believe that it may have possibly had something to due with the requirement which can sometimes one of several possible causes for not receiving a file properly on the upload field.

    Anyhow though, I've run two separate tests of this issue with both Drive and Dropbox connected and I found that I was able to receive everything without an issue. 

    Have you tried clearing your browser cache and then attempting the integration it again?

    How often does this happen?

     

    Drive Test:

     

    Dropbox Test:

     

  • Profile Image

    Answered by exchangepress on April 30, 2015 at 02:47 PM

    I still can't seem to remedy the issue.  I have tried:

    - Clearing my cache

    - Removing the integrations and adding them back in

    - Deleting all existing responses

    - Cloning the form

    - Having someone else complete the form

    In all cases I am still only getting the file folder and the PDF summary in both Google Drive and Dropbox, no uploaded files.

  • Profile Image

    Answered by exchangepress on April 30, 2015 at 03:07 PM

    I did another test by creating a new form with file uploads.  That form worked fine, so it must be something particular to the form that his having the issues.  Since the problem just started yesterday, would it be possible for you to view the changes I made to see if you can identify anything that might have triggered the issue?  I was testing the Expiration Date Limit and had an issue that was resolved.  Maybe this is somehow related?  We need this form to go live tomorrow so I'm in a major time crunch.  I could recreate the form, but I'd like to avoid having to do that if possible.

  • Profile Image

    Answered by Ben on April 30, 2015 at 04:48 PM

    Could you please check and let us know if you have received the files at this time?

    I have submitted your form 50485747049161 and got a thank you page shown that my application ID is 21.

    If this one was working for you, then you should log into your account and revert to the form at the first yesterdays change (at 1:51 AM).

    You can see how to do that here: How to View Form Revision History

  • Profile Image

    Answered by exchangepress on April 30, 2015 at 05:16 PM

    Yes, I have your documents!  I need a bit of help identifying the right version though.  The only choice that has 51 minutes is listed at 4:51pm.  I'm guessing this could just be a time zone thing, but I want to make sure before I revert.  Below is a screenshot of the options I see.

  • Profile Image

    Answered by Ben on April 30, 2015 at 05:26 PM

    Great to hear that you got them :)

    Now you are correct about the time zone, I am in Europe, so there might be a small difference (about 1 cm of difference based on world clock)  :)

    The option that I am referring to is the one right above the segment with changes made on 28th of April.

    You could experiment by starting with the last change if you wish for that day and go down to this one.

    Once you finish, just let us know and we will be happy to remove these test submissions from your account.

    Do let us know if you have any difficulties and need our assistance and we would be happy to assist.

  • Profile Image

    Answered by exchangepress on April 30, 2015 at 06:02 PM

    Well, it seems I picked the wrong version because it still doesn't work.  And, it seems I can no longer revert to versions older than the one I reverted to.  Is there any way to remedy this?

  • Profile Image

    Answered by Ben on April 30, 2015 at 06:23 PM

    Unfortunately it is not possible to revert to the version after the one that you revert to, at least to my knowledge.

    Did you make any changes to the form after reverting back to it by some chance?

    If you did, please try to remove the same changes and add only Google Integration and test with a submission each time you make a change.

    Doing that will help you see which exact change makes the issue.

    To help, I have cleared your forms cache just in case as well so you can first try to re-submit the form again.

  • Profile Image

    Answered by exchangepress on May 01, 2015 at 02:52 PM

    I tried recreating the form entirely (not cloning it) and I am having the same problem again.  What configuration in this form could possibly be causing this problem?

  • Profile Image

    Answered by Ben on May 01, 2015 at 04:25 PM

    Unfortunately nothing in the form should cause these issues.

    I just did another test by cloning your form and then integrating to Google Drive, saving it and submitting.

    Once I saw the files in there, I went to the form again and added DropBox integration, but it too seems to be working just fine - both are when both are added.

    Is there any point as you made the form where you have noticed it not working?

    By all things set up, I can not see a reason why it would not.

    Also, do check if your DropBox and Google Drive have enough space available.

    I was able to take a look at your DropBox folder organization and based on that, there should be no issues and I presume that the same setup is done for Google Drive as well.

    Can you tell us if you have tried to have only one of the integrations working on your form (not both of them) and see if that works for you?

  • Profile Image

    Answered by exchangepress on May 01, 2015 at 06:44 PM

    I don't know why this didn't occur to me before!

    I have a second form that I am using to send people the link to continue their application later (described here).  That form is http://form.jotform.us/form/50646694220152.    I also had the Thank You directed to a custom URL to pre-populate the fields on the first page (as described at the bottom of the How to Save... instructions and here).  My URL was:

     

    http://form.jotformpro.com/form/51195909463968?session={email1}&yourName[first]={name1:first}&yourName[last]={name1:last}&organization={organization}&position={position}&email={email1}

    This is the form that seems to be the problem.  When I start with the form we have been working on rather than this form, the files appear just fine.

    I tried reducing the Thank You URL to both of the following:

    http://form.jotformpro.com/form/51195909463968?session={email1}&email={email1}

    http://form.jotformpro.com/form/51195909463968?session={email1}

    None of this worked.  Any ideas with this new info?

  • Profile Image

    Answered by raul on May 01, 2015 at 07:44 PM

    I don't think the prepopulated URL would have an impact on the integrations of your second form, but just to confirm the integration stopped working when you started using the Save and Continue method?

    I will make some tests on my side to check if I'm able to reproduce the issue using this method and let you know.

  • Profile Image

    Answered by raul on May 01, 2015 at 09:56 PM

    After further testing, I was able to determine that this indeed happens because of the save and continue method that you are using in your form.

    When the form is filled using the session variable the uploaded files are not transferred by the integration, but when it's filled using its direct link (without the session parameter) it works as expected.

    Let me pass this thread to our development team so they can check it out and you'll be notified here once we have an update regarding this matter.

  • Profile Image

    Answered by exchangepress on May 04, 2015 at 11:19 AM

    Thanks Raul,

    Yes, it seems the form stopped working when I populated the save and continue.  It was working previously with that link though.  This form is now public so the sooner this is resolved the better.

    Thank you,
    Jennifer

  • Profile Image

    Answered by Ben on May 04, 2015 at 11:34 AM

    I would recommend at this time to use the other - similar feature and that would be AutoFill. You can see how to set it up here: How to Enable Auto Fill Feature.

    Unlike the save for later feature that uses sessions from our servers (which are most likely the ones causing this issue) this feature uses the browser itself to store the data for the amount of time that you have specified.

    It will allow them to continue later, but only over the browser that they had originally used, not over a different browser / system as the sessions allow.

    Hope that this would be a good alternative for you Jennifer and that it will work properly.

  • Profile Image

    Answered by exchangepress on May 04, 2015 at 12:07 PM

    Hi Ben,

    That is not a viable option for us because there is a high probability that our applicants will use more than one device and/or clear their cookies before they submit the form.

    What's perplexing is that these forms were working as originally configured.  There is no logical reason on the front end for this not to work; the forms are configured according to JotForm's own instructions (as listed above).  There shouldn't be any reason for these URLs to impact the integrations.

    I understand there is not much else you or your support colleagues can suggest so I anxiously await a response from the developers.

    Thanks,
    Jennifer

  • Profile Image
    JotForm Support

    Answered by Welvin on May 04, 2015 at 01:13 PM

    Our apologies if this problem is causing you any troubles and inconveniences, Jennifer. Yes, when enabling/using the auto-fill feature, you should discourage your applicants from clearing their browsing preferences (Cookies, Offline Site Data and Cache) so the data will remain saved in their browser.

    Anyway, the thread is already assigned to our developer and I have just sent a follow-up. If there are updates, you should know be notified about it in this thread.

    Your patience and understanding on this matter are highly appreciated.

    Thanks

  • Profile Image
    JotForm Support

    Answered by alp_deniz on July 12, 2015 at 06:36 PM

    Hello,

    The problem seems to be fixed as I am now able to see my files in Google Drive. 

    Please let us know if the issue is still there for you so that we will replicate and solve it.

    Kind regards