Image Choices Widget won't show a warning error (in red) when set as required

  • Profile Image
    aprpac
    Asked on May 06, 2015 at 03:26 AM

    Hi,

    1) On the form the Required image picker does not error correctly if you try to Submit the form without selecting your choices. You see a message flash up at bottom for a split second but it disappears. Also no red line appears around the images.

    2) I have tried using the Preview Before Submit widget, but this does not work with the image picker - is this a bug?

    3) Also no red line appears around the Required Year field. It would be better if the missing field also showed a message such as "The Year must be provided" - is this possible?

    Please can you help.

    Thanks

    Paul

     

  • Profile Image
    Ben
    Answered on May 06, 2015 at 09:19 AM

    Please note Paul that we can only handle one issue per thread so when you have multiple issues / questions, do open 1 thread per issue instead of combining them into a single thread.

    For this reason I have now moved the other questions to new threads.

    The one about Preview Before Submit has been moved here: http://www.jotform.com/answers/564931

    The other about the error highlighting on the dropdowns used for date has been moved to here: http://www.jotform.com/answers/564934

    Now in regards to your first issue. I took a look at your jotform, but from what I can see the Image Picker widget is empty and as such just shown as a (non required) label right above Submit button.

    The Image Choices widget that is above and used for icons seem to be working properly for me.

    Can you tell us if the error you have happens when the jotform is embedded to your page only?

  • Profile Image
    aprpac
    Answered on May 06, 2015 at 09:39 AM

    Hi Ben,

    Thanks for your help. Sorry about the number of queries and thanks for splitting them up for me.

    Sorry I have confused things by using the wrong widget name. It is the Image Choices that is the problem. To replicate simply follow URL provided and click Submit button. 

    A light red line appears around some of the non-completed fields, but there is no error indication for the Image Choices (Wedding Icons  & Ribbon Colours). Now if you complete all of the other fields apart from the Image Choices the error message flashes up briefly but there is no other indication as to why you can't submit the form.

    I am using Safari web browser but have tried and is the same in Internet Explorer.

    Thanks

    Paul

  • Profile Image
    Mike_G
    Answered on May 06, 2015 at 12:31 PM

    After running several test, I still cannot make the "required" error warning message and the "red" warning around the Image Choices widget appear perfectly. I have noticed some errors in the widget and I will have to raise this concern to our developers so they may look into it deeply. I'm sorry for any inconvenience this have caused you. We'll keep you posted on this thread as soon as we find solution to the issue. Thank you. 

  • Profile Image
    aprpac
    Answered on May 06, 2015 at 05:43 PM

    Thanks - however I have now switched to using the Image Picker as this works better for my needs as 1) It works with the Preview Before Submit widget & 

    2) The selected images are included within the emails sent - this is excellent.

    I do have a couple of issues with Image Picker, but will open new threads.

    Thanks

    Paul

  • Profile Image
    TitusN
    Answered on August 10, 2016 at 08:41 AM

    Image choices will show the required validation error as expected. 

    Please give it a try and let us know.