Jotform not working in firefox

  • Profile Image
    tidickerson
    Asked on May 12, 2015 at 09:08 AM

    I am using squarespace and my jotform works fine in chrome and ie but doesnt show up in firefox or opera. Opera blocks it saying its not from a secure source. Any suggestions?

     

    Thanks in advance!

  • Profile Image
    david
    Answered on May 12, 2015 at 11:49 AM

    Hi,

    I checked your form in FireFox and it appears to be working just fine:

    If you embedded your form into a secure page using the non-SSL embed code, your browser may be giving you a mixed content warning.  Since the form isn't using HTTPS and the page is, that may be why the form is not showing up. 

    Try replacing your embed code with the iFrame embed code:

    http://www.jotform.com/help/148-Getting-the-Form-iFrame-Code

    This should insulate your form from the rest of your page and allow it to function the same way accross all browsers.  If it does not, let us know and we will be happy to have another look.

  • Profile Image
    InfiniteEnergy
    Answered on September 16, 2015 at 01:41 PM

    So the answer is to use iframe for HTTPS forms?  We use it on HTTPS pages and have the HTTPS script inserted and it still doesn't work on FireFox.

    Why would it not display properly in FireFox but work on all other browsers?

  • Profile Image
    david
    Answered on September 16, 2015 at 02:58 PM

    There may be something specific to your FireFox settings that is not allowing it to load properly.  I checked in a few version of FireFox and the embedded form showed up without issue in each one:

    Usually, FireFox will display things that most other browsers won't, it is quite odd that it is the other way around for you.  If something displays in most browsers, it almost always displays in FireFox.