What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    I'm trying to calculate a series of inputs with predefined inputs of 0-

    Asked by escarecard on May 14, 2015 at 09:26 AM

    I'm trying to calculate a series of inputs with predefined inputs of 0-12. When calculating, the form seems to see 0 as 1, 1 as 2 even though the calculation values are set as 0-12.

    Is the form calculation unable to recognise a zero value?

    Thanks!



    This is a re-post of a comment on How to Perform Form Calculation Using a Widget

    form calculation calculation values
  • Profile Image

    Answered by Sammy on May 14, 2015 at 12:00 PM

    If i may ask what type of calculations are you performing and also which form element are you using to hold your predefined values.

    Also you can check that the inputs in the from are set to numerical values and not alphanumeric.

    To do this open the calculation form wizard by clicking on the wand button

    Makes sure the value type for the fields reads 0-9 and not a-z save the changes and then try your calculation again.

     

  • Profile Image

    Answered by escarecard on May 15, 2015 at 04:39 AM

    Hi Sammy

    I've checked the above and all seems correct. The values are in a Drop Down form element and are 0-12 and in the calculation field it's basic addition. The calculation seems to be taking the zero value as a 1 and so forth. 

     

    Thanks

  • Profile Image

    Answered by escarecard on May 15, 2015 at 04:51 AM

    Hi - there appears to have been a problem with the initial field that was screwing up the calculation. I've deleted it and it's fine now. Thanks for your help...

  • Profile Image
    JotForm Support

    Answered by Boris on May 15, 2015 at 08:30 AM

    On behalf of my colleague, you are kindly welcome.

    Thank you for letting us know that you've managed to resolve the issue.

    If you need further help or assistance, please contact us again. We are here to help.