I'm trying to calculate a series of inputs with predefined inputs of 0-

  • Profile Image
    escarecard
    Asked on May 14, 2015 at 09:26 AM

    I'm trying to calculate a series of inputs with predefined inputs of 0-12. When calculating, the form seems to see 0 as 1, 1 as 2 even though the calculation values are set as 0-12.

    Is the form calculation unable to recognise a zero value?

    Thanks!



    This is a re-post of a comment on How to Perform Form Calculation Using a Widget

  • Profile Image
    Sammy
    Answered on May 14, 2015 at 12:00 PM

    If i may ask what type of calculations are you performing and also which form element are you using to hold your predefined values.

    Also you can check that the inputs in the from are set to numerical values and not alphanumeric.

    To do this open the calculation form wizard by clicking on the wand button

    Makes sure the value type for the fields reads 0-9 and not a-z save the changes and then try your calculation again.

     

  • Profile Image
    escarecard
    Answered on May 15, 2015 at 04:39 AM

    Hi Sammy

    I've checked the above and all seems correct. The values are in a Drop Down form element and are 0-12 and in the calculation field it's basic addition. The calculation seems to be taking the zero value as a 1 and so forth. 

     

    Thanks

  • Profile Image
    escarecard
    Answered on May 15, 2015 at 04:51 AM

    Hi - there appears to have been a problem with the initial field that was screwing up the calculation. I've deleted it and it's fine now. Thanks for your help...

  • Profile Image
    Boris
    Answered on May 15, 2015 at 08:30 AM

    On behalf of my colleague, you are kindly welcome.

    Thank you for letting us know that you've managed to resolve the issue.

    If you need further help or assistance, please contact us again. We are here to help.