What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Having problem using 2 separate lightbox forms on single page

    Asked by speakwellesl on May 27, 2015 at 02:07 PM

    Hello!

    First of all- JotForm is amazing! thanks you all for creating and sharing such an awesome tool. The customization and integrations are incredible. I'll highly recommend JotForm to all my clients!

     

    I've created 2 forms. I integrate both as lightbox forms on my squarespace page here:

     

    http://www.speakwellesl.com/services/

     

    The topmost form works fine. Clicking the 'GET A QUOTE' button loads the lightbox form correctly.

     

    The second form doesn't work properly. When I click the bottom-most 'GET A QUOTE' button the lightbox form for the first button appears instead of the lightbox form for the second form. I've pasted the lightbox code directly from JotForm and doublechecked it.

    NOTE: The second form was a "clone" of the first- perhaps something got entwined from the 1st form which is causing the issue?

     

    Any help would be most appreciated. I'll try creatign another form from scratch instead of as a clone to see if that resolves the issue.

     

     

    Page URL:
    http://www.speakwellesl.com/services/

    problem lightbox forms lightbox form JotForm integrations another form
  • Profile Image
    JotForm Support

    Answered by Kiran on May 27, 2015 at 03:36 PM

    As I check your webpage, I see that the both forms are displayed correctly without any issue at my end. Please see the screenshot below :

    It seems that there is an issue with the browser cache. Please try clearing the browser cache and check if the forms are loading correctly. Please follow the steps provided in the guide below :

    http://www.wikihow.com/Clear-Your-Browser%27s-Cache

    I've also cleared the forms cache from my end to see if that helps. Please get back to us if you need any further assistance. We will be happy to help.

    Thanks!

  • Profile Image

    Answered by speakwellesl on May 27, 2015 at 04:16 PM

    Thanks Kiran. I fixed the issue before you investigated it.

     

    The problem is that a cloned form in lightbox mode will only display the original form. To reproduce the issue:

     

    1) Make a form, embed it as a lightbox on your page.

    2) Clone the form, modify the cloned form, and embed it as a lightbox on your page.

    3) Clicking the second embedded lightbox link will result in the first, original form displaying, not the modified cloned form.

     

    Thanks for looking into it! 

  • Profile Image

    Answered by raul on May 27, 2015 at 05:43 PM

    On behalf of my colleague, you're welcome.
    Feel free to contact us again, should you require our assistance.