Delay in receiving submission emails form form.

  • Profile Image
    maorimusic
    Asked on May 28, 2015 at 06:31 AM

    I've noticed an appreciable delay (an hour or more) today (Thursday MAY 28th) between a form being completed by a client and my receiving an email notification today.

    Is this an ongoing technical problem at JotForm?

  • Profile Image
    ecem
    Answered on May 28, 2015 at 07:38 AM

    Hi,

    I made a test submission in your form and it took a few seconds to upload the file and submit the form. You can check my submission.

    The issue you've seen could be due to some temporary disturbances in the network. 

     

    Hope this information helps.

    Let us know if you need further assistance.

    Thanks.

    Ecem

  • Profile Image
    maorimusic
    Answered on May 28, 2015 at 08:47 AM

    Hi Ecem,

    Thanks for looking into this.

    Whilst your own test transmission did indeed only take minutes to come through, I am STILL waiting for similar test transmissions I made at 11-19am, 11-40am and 1-30pm to appear by email (all of them are shown on the SUBMISSIONS part of my JotForm site, however).

    Interestingly, your email confirmation of your own message has only just arrived (1-40pm) but the transmission time is shown as 12-36pm.

    Other test email messages I've made assure me that there isn't a problem with my own mail server.

    Is there a problem with JotForm's outgoing mail servers at all that could be causing such delays?

    Regards,

    Nev

  • Profile Image
    maorimusic
    Answered on May 28, 2015 at 10:34 AM

    Hi,

    Further to the above - I am STILL waiting for the "test" submissions I input to come through.

    Interestingly, I note that I can FORWARD my test submission from my JotForm site and this comes through to my email address promptly.

    The question remains, what is preventing the submissions from automatically being forwarded to my email address?

    Nev

    Maori Music Publishing 

  • Profile Image
    ashwin_d
    Answered on May 28, 2015 at 11:59 AM

    Hello maorimusic,

    I did check your form's notification email alert and did not find any issue with that. I sent a test submission by using your embedded form. I also monitored our email logs and it seems the submission email was sent almost instantly. Please check the log below:

    [2015-05-28 11:51:46] Submission #308637505836575059 Form #41704719954361 SENT to maori@maorimusic.co.uk from noreply@jotform.com via AMAZONSES 

    I do not see any reason of delay in receiving submission emails unless it is getting delayed in your email server.

    Please be noted that it is also possible to use your own email address to send submission emails. You will have to add Custom Sender email in your account. I would suggest you to please add custom sender email in your account and see if that solves your problem. The following guide should help you:

    http://www.jotform.com/blog/86-Send-Form-Emails-From-Your-Own-Email-Address-JotForm-Now-Support-SMTP 

    http://www.jotform.com/help/236-How-to-use-Mandrill-to-Send-Emails-From-Your-Own-Email-Address 

    Hope this helps.

    Do get back to us if the issue persists.

    Thank you!

  • Profile Image
    maorimusic
    Answered on May 28, 2015 at 06:27 PM

    Many thanks - this seems to have now solved the delay problem.

     

    Nev

    Maori Music Publishing (UK) Ltd

  • Profile Image
    raul
    Answered on May 28, 2015 at 06:45 PM

    On behalf of my colleagues, you're welcome.
    Feel free to contact us anytime, should you require our assistance.

  • Profile Image
    Clos
    Answered on October 28, 2016 at 08:10 AM

    Hi,

    I thought there was a huge delay as well, but actually it's not a delay at all, the emails where sent right away, it's just that they had been labeled as SPAM by my gmail account...

    Of course, I created a filter to avoid that in the future, but still many people will probably never receive the confirmation email jotform send.

    Ben

  • Profile Image
    Nik_C
    Answered on October 28, 2016 at 10:02 AM

    Hello Ben,

    Thank you for letting us know about your solution.

    It will be helpful for our users if they encounter similar problem.

    Thank you!