Conditions not working..

  • Profile Image
    pwedgwood
    Asked on November 20, 2011 at 11:06 PM

    I am trying to hide certain fields on the form based on the radio button selected in the first field.  Only a few of the condidtions I have tried to set are working.  I'm also finding that the "preview" option sometimes retains fields that have been deleted in the "edit" screen of the form.  I am keen to introduce the use of Jotform across our business and trying to make a solid working example to present to our senior management team.

    Any help would be appreciated,

  • Profile Image
    abajan
    Answered on November 21, 2011 at 04:20 AM

    This may sound like a pretty drastic measure but delete all six conditions and start afresh. Now, replace them with the following four:

    Hide Duration of symptoms field when (if) Consult field equals to Follow-up
    Hide Duration of symptoms field when (if) Consult field equals to No show:


    Hide Relatedness field when (if) Consult field equals to Follow-up
    Hide Relatedness field when (if) Consult field equals to No show:


    Hide Workgroup field when (if) Consult field equals to No show:


    Hide Body area field when (if) Consult field equals to No show:


    The summary of conditions should look like the following when "Saved Conditions" is clicked:

     

    You would have noticed that the first two conditions each combine two rules. The highlighted conditions in the below screenshot of your original setup were the ones that were combined:

    The "Add New Rule" button (see the first two images above) is used to perform that operation.

    Here is a clone of your form with the conditions working.

    I have no idea why your current conditions don't work but it's usually best to confirm that a condition works as expected before adding new rules and/or conditions and that was the procedure I followed after deleting the original conditions from the clone.

  • Profile Image
    pwedgwood
    Answered on November 21, 2011 at 04:45 AM

    Thank you for such a prompt reply.  With support like that I think this product just sold itself! Fantastic.

  • Profile Image
    abajan
    Answered on November 21, 2011 at 06:30 AM

    Glad to be of service :)

  • Profile Image
    ymedia
    Answered on April 02, 2013 at 08:06 PM

    Hi guys,

    I know this is an old post, but I'm having the same trouble! I have all the conditions set up and they look and read exactly as above. However I just can't get the form to work in preview mode or once in set into the website. Here is the link for the website:

    http://www.newspaperhouse.com.au/index.php/y-media

  • Profile Image
    abajan
    Answered on April 02, 2013 at 09:02 PM

    @ymedia

    I'm not sure I understand the problem because both the Stock and Card Stock fields are being hidden when Banners is selected as the product. This is exactly how your conditions (whose summary is pictured below) have been configured:


    Incidentally, those rules could have been combined into a single condition:


    Please elaborate on the behavior you want exhibited by the form: State exactly what is to happen as the vaious choices are in the Product field are selected.

    Thanks.