What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Submissions not populating Configurable List widget, Dynamic Dropdown widget and other plain forms fields when in edit mode

    Asked by acase on June 04, 2015 at 01:12 AM

    The dynamic drop downs and configurable list are going blank once the form is edited, is their a fix for this? We have tried multiple browsers and the form works best on Firefox. We have 100+ responses so far but are missing alot of data from edited forms.

    Page URL:
    http://form.jotformpro.com/form/51265243828962

    dynamic drop down configurable list on edit configurable
  • Profile Image
    JotForm Support

    Answered by Charlie on June 04, 2015 at 03:16 AM

    Hi,

    I've cloned your form for testing purposes, unfortunately, I'm unable to replicate the problem.

    1. Screenshot of my form when using the edit link submission.

    2. Screenshot of my form when in edit mode in the submissions page.

     

    I've tested it on Chrome browser, I clicked submit and data were updated. Have you tried clearing your form's cache and your browser's cache? Your browser might be loading your previous sessions white doing some test in your form. Could you also try viewing the edit forms in incognito mode. 

    Also, does this happen on a desktop computer or in mobile devices? Please do try the said solutions above and let us know if that fixes the problem.

    Thank you.

  • Profile Image

    Answered by acase on June 04, 2015 at 09:54 AM

    The problem is both PC and Mobiile

     

  • Profile Image
    JotForm Support

    Answered by Charlie on June 04, 2015 at 11:57 AM

    Hi,

    I was able to replicate the problem by checking your submissions Can you confirm if this happens to all of your submissions?

    I'll need to forward this to our developers to have it check at the back end, but it seems like an isolated case in your end.

    Apologies for the inconvenience, we'll update you as soon as we hear any news from the back end team.

     

  • Profile Image

    Answered by acase on June 04, 2015 at 12:03 PM

    It looks like out of 144 submission that use this information 87 of the forms are missing data.  Please let me know asap or if you have an alternative, we have already paid for this and gone live not realizing this was going to be an issue and it is causing major problems.

    Thank you for your help!

  • Profile Image
    JotForm Support

    Answered by Charlie on June 11, 2015 at 03:40 AM

    Hi,

    We're continuously investigating this matter. I've noticed that your "Vender 1 Bill To:" does not have any selections on it, but your form says that it is required and conditionally sets the Configurable list widget to show.

     

    There are a lot of your submissions that does not have this field, in your earlier version of your form, was this set to required already with conditional logic? Or only when the form was updated recently? Also, did those submissions originally have a value on it or it was intended to be blank on your earlier version of the form? If this is the case, when you update or edit the submission, the updated form will be used. 

    We'll wait for your confirmation. Apologies for the inconvenience.

  • Profile Image

    Answered by acase on June 30, 2015 at 11:15 AM

    We added this a few days after we started using the form so yes some of them will be blank. We also changed some of the logics so if information is filled out they cannot skip past that page on approval since this was causing those fields to go blank.  But they are still able to skip over information and I cannot prevent it with how the form is currently set up and I really don't want to make many more changes.  Example if they fill out purchase order and then go back and edit and chose workorder only so they can skip the purchase order it is deleting the purchase order information.

  • Profile Image
    JotForm Support

    Answered by Charlie on June 30, 2015 at 01:04 PM

    I believe that would be the reason for the problems. It seems like the original design of the form and the new changes with complex conditional logic and setting different changes in the form is causing a conflict when you are editing the submissions. Example is this, setting up previous fields to be required when originally it is not, when you are in edit mode, the required field will be followed.

    Regarding this question:

    "Example if they fill out purchase order and then go back and edit and chose workorder only so they can skip the purchase order it is deleting the purchase order information."

    Could you give us a sample workflow how we can recreate it and if you have a test submission that we can check for this?

     

    Overall, you might need to re-design or re-check the workflow process of your form. I would recommend that you clone your form and make the changes and further test the process there.

  • Profile Image

    Answered by acase on June 30, 2015 at 04:50 PM

    An example ticket would for be a Field Employee to Start by checking purchase order only and completing that part of the ticket and receiving an edit email.  After they have completed the work they would go back and edit submission and change it to Purchase Order & Workorder and complete the workorder part of the ticket.  Once they are done they will send for manager review and the manger would approve the ticket.

    So if i understand what you are saying i should clone my form and it will work correctly, that the error is caused by the changes I have made and it is trying to default to the previous settings?

  • Profile Image
    JotForm Support

    Answered by david on June 30, 2015 at 06:49 PM

    Cloning the form and using the clone may indeed resolve the issue.  I checked the widgets in my clone of your form and each one appears to import the data to the form when I use the edit link:

    While they look for a cause as to why this is happening, this could be fix that works.  It will load the most recent code for widgets and such and so far, my clone, is loading the submitted data into the form.

  • Profile Image

    Answered by acase on July 07, 2015 at 12:39 PM

    We are going to go ahead and give this a try, is there an easy way we can have the old form go straight to the clone so we don't have to send out a new link?

  • Profile Image
    JotForm Support

    Answered by david on July 07, 2015 at 12:48 PM

    Short of embedding the new form in the old form, you would need to use a new link for the new form.  You could replace the widget in your form with a new copy, however, you would lose the previously collected data associated with the widget.

  • Profile Image
    JotForm Support

    Answered by TitusN on August 11, 2016 at 05:23 AM

    We've made a few updates to fix both the configurable list and the dynamic dropdown widget. The will load their submission data when editing a particular submission. 

    Please give them another try - and let us know. 

    Thanks!