What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    SSL Warning on Mobile when using https://secure.jotform.com

    Asked by daniele.giombelli on June 05, 2015 at 03:58 AM

    Hello everyone. I have a problem with my forms: they seem to be correctly visualized on any mobile device only by requesting desktop site view at least the first time (I'm using chrome for android). Otherwise the form is rendered as if there was no theme. They are all linked to a single design theme.

    Here's an example:

    Before requesting desktop ua

    And here's after:

    Link: https://secure.jotformeu.com/form/33255546856362

    Any help? Thanks a lot!

    Page URL:
    https://secure.jotformeu.com/form/33255546856362

    Mobile mobile responsive responsive
  • Profile Image
    JotForm Support

    Answered by Jan on June 05, 2015 at 10:42 AM

    I was able to replicate your issue on my Android phone using Google Chrome. I cloned your form and found out that the responsive functionality are not enabled.

    Please refer to this guide: http://www.jotform.com/help/311-How-to-make-forms-Mobile-Responsive

  • Profile Image

    Answered by daniele.giombelli on June 08, 2015 at 03:35 AM

    Thank You very much for your quick response. I tried doing what you suggested, but unfortunately, it didn't work. The forms are still looking theme-less...

  • Profile Image
    JotForm Support

    Answered by Welvin on June 08, 2015 at 08:29 AM

    Unfortunately, I cannot replicate the problem here. Here's how the form appeared to my end using an actual android device:

     

    Maybe, the problem is related to your internet connection or could be because of your Chrome configuration. Did you check it with the default Android Browser? If it's working there, then the issue is related to your chrome installation. Can you also ask your colleague to check?

    Thanks

  • Profile Image

    Answered by daniele.giombelli on June 09, 2015 at 03:31 AM

    Unfortunately, the problem isn't solved yet. Every colleague of mine with Android default browser, Chrome, Firefox and on Apple Iphone devices sees the forms without theme (and some costumers did too, which isn't good). I tried to make a new theme identical to the one applied to this, but it didn't work. I think maybe if you clean the cookies in your android browser, then the form will reverse to themeless mode... Honestly, I'm clueless. Any other ideas? Thank You very much,

    Daniele.

  • Profile Image

    Answered by daniele.giombelli on June 09, 2015 at 04:12 AM

    Edit: I tried to make and apply another theme, but nothing changes.

    Anyway, the problem has been present for no more than three weeks. Before that, there was no issue. Also, I wanted to add that when you came up with the theme store, and I created the first theme, I couldn't apply it correctly to all my forms without having some graphical issue of some sort. So I had to erase the costum injected Css in all the forms and then apply the theme. After the theme was applied to the blank forms, they finally looked all the same. But now I wonder if I screwed up, because it really looks like the mobile ua cannot see the theme unless you switch to desktop ua... Oh well, hope this bit of info can help. Thank You,

    Daniele.

     

    PS I's no connection issue, as it doesn't chanhe anything whether I'm connected to a wi-fi, or 3G, or at a costumer's, or my home's...

  • Profile Image

    Answered by thespanishfactory on June 09, 2015 at 06:24 AM

    The problem of this is that JotForm is not compatible with SSL on mobiles. I advised about this a while ago. I had this problem for months. (As you can see, before you had the green lock in the url and now not)

    This can be solved if you change the URL of the embed code in the website:

    Link: https://secure.jotformeu.com/form/33255546856362

    NEW:  https://www.jotformeu.com/form/33255546856362

    Change "secure" for "www"

  • Profile Image

    Answered by daniele.giombelli on June 09, 2015 at 06:34 AM

    Wow. that works. thespanishfactory I cannot thank you enough.

    To jotform support: this is not very funny though. SSL on forms which contain sensible data... Kind of important. Are you working to solve this? I work in the insurance field, the forms are used to collect data that are always sensible, for the custody of which my firm is directly responsible. I don't feel comfortable switching the link to a non secured one. Thank You for your patience.

    Daniele.

  • Profile Image

    Answered by thespanishfactory on June 09, 2015 at 06:46 AM

    It's OK my friend, I really undertand your level of frustration.

    The problem of the customer service here in JotForm is that if you are not lucky enough to get someone who really care about your problem and what you are reporting, you are ignored in the limbo of the irrelevant replies. Looks at the replied that they just provided you, as this was a problem of the responsiveness of the form.

  • Profile Image
    JotForm Support

    Answered by Welvin on June 09, 2015 at 07:13 AM

    Hi Daniele,

    The form is still secure. As you could see it, it is still using our HTTPS link. A non-secure form starts with HTTP://WWW or HTTP://FORM. Secure Form starts with HTTPS://SECURE and HTTPS://WWW.

    Our apologies if we are missing this simple solution to fix the problem. But will forward this matter to our developers so they can check further. HTTPS://SECURE should supposed to work in any device/browser.

    Thanks

  • Profile Image

    Answered by thespanishfactory on June 12, 2015 at 07:37 AM

    I just want to advise that the solution of adding www to the embed code, does not work anymore. Jotform messed around again and changed this without any notice even when this was a solution they provide in other post.

     

    Thank you jotform! I was a whole day with my forms not showing in my website.

  • Profile Image
    JotForm Support

    Answered by Jan on June 12, 2015 at 08:56 AM

    @thespanishfactory

    We will answer your inquiry in the thread that you created.
    http://www.jotform.com/answers/587214-AGAIN-Unsecured-Form-SSL-Warning-when-Secured-Form-is-Submitted-on-MOBILE#0

  • Profile Image

    Answered by daniele.giombelli on June 15, 2015 at 04:41 AM

    Update: the forms now can be visualized correctly, even with te "secure" subdomain, but it still persists the ssl warning, with the "secure" subdomain only (It's the same problem reported in this thread: http://www.jotform.com/answers/587214-AGAIN-Unsecured-Form-SSL-Warning-when-Secured-Form-is-Submitted-on-MOBILE#0, which I will continue to follow).

    I wanted to thank you for your support. Despite the issue still not being completely resolved, I think the response you provide to customers is punctual, even if sometimes the problem is not immediately identified (but we're humans).

    Bottom line, we can say, after one year and a half, that we are happy with JotForm, and confident you'll always provide a prompt customer care service.

    Un saluto dall'Italia.

    Daniele

  • Profile Image

    Answered by Shadae on June 15, 2015 at 10:07 AM

    Hi Daniele,

    We do apologize for the issue that you are still experiencing regarding receiving security errors on your form. As stated in this thread: http://www.jotform.com/answers/587214 our developers are working urgently to have the issue resolved as quickly as possible.

    We are however happy to hear that your forms are now being displayed correctly with your theme.

    We are happy to provide you with the best support possible in the shortest time to ensure that your issues have been resolved.

    I have created a ticket on this thread so that you will be updated once the issue has been resolved.

    Thank you

     

  • Profile Image
    JotForm Support

    Answered by alp_deniz on June 22, 2015 at 08:50 AM

    Hello Daniela,

    The problems related to secure domain have just been fixed.

    Thank you very much for your understanding.

    All the best!