I can't set a particular field to be conditionally required

  • Profile Image
    carolturner
    Asked on June 05, 2015 at 04:36 PM

    I am trying to add a condition as follows, but the UNREQUIRE MULTIPLE field is highlighted in PINK and I can't save it. I have set the same sort of condition for other fields based on the Volunteer Effort field and have had no problems.

    if Volunteer Effort = Sending a class treat (requested by a Teacher or Home Room Parent)

    REQUIRE Grade

    UNREQUIRE MULTIPLE Home & School Function, radioField(id12), Hours Logged, Group Served, Chaperon Hours Logged

     

     

     

  • Profile Image
    Mike
    Answered on June 05, 2015 at 05:43 PM

    Thank you for contacting us.

    It seems that you have fixed the issue by hiding some fields.

    If the issue still persists, please let us know. We will be happy to help.

  • Profile Image
    carolturner
    Answered on June 05, 2015 at 05:54 PM

    I haven't solved the issue of making the field Grade required. I don't have a problem with hiding/showing. I need the field to be required when Send a class treat is selected AND I CAN'T.

     

    Thank you.

  • Profile Image
    Mike
    Answered on June 05, 2015 at 06:20 PM

    Please try with the following condition:

    if Volunteer Effort = Sending a class treat (requested by a Teacher or Home Room Parent)

    Require Multiple = Grade

    Please note that alternative unrequire conditions are usually not needed. The same is true for show/hide conditions. For example, if you apply the Show conditions to some field(s) you do not need to add corresponding Hide conditions.

    Thank you.

  • Profile Image
    carolturner
    Answered on June 05, 2015 at 06:29 PM

    Shut the front door. That worked. By using the REQUIRE MULTIPLE, I was able to use the UNREQUIRE MULTIPLE. Do they have to match (*MULTIPLE) or something?

    Thank you!

  • Profile Image
    Chriistian
    Answered on June 05, 2015 at 11:51 PM

    Hi carolturner, 

    On behalf of my colleague, Mike, you are welcome!

     

    Glad to hear that your concern was solved.

     

    As I checked, when you used the REQUIRE/UNREQUIRE MULTIPLE must match to work. However, as noted by my collegue, Mike, that alternatively unrequire conditions are usually not needed. The same is true for show/hide conditions. For example, if you apply the Show conditions to some field(s) you do not need to add corresponding Hide conditions.

     

    Regards.