User's submission problem

  • Profile Image
    jcsmuseum
    Asked on June 09, 2015 at 02:36 PM

    Not sure if this is a user issue or trouble with WordPress but we are using the code widget from JotForm. Our account is under jcsmuseum. 

     

    Here is a description of the form submission issue. 

     

    "I don't know if its a glitch in the Out-of-the-Box entry form or my

    computer but six times in a row I've had to refill the application form

    (which jumps around from one view to another) only to get to the bottom

    of the entry with everything filled out and downloaded and hit "submit",

    and that's the end. No link to another step, no jump to pay the fee,

    nothing. Even parts of the screen are block by blank boxes. Four of the

    six tries,  the "Submit" button didn't appear and it wasn't available, so

    I start over. So I use a different browser, but when I go to download my

    pictures, it gives the option to "Open" rather than "Choose" or "Select".

     

    At any rate, I'm at the point now to forget the whole thing. I need to

     

    make sculpture, not waste hours at the computer."

  • Profile Image
    Mike
    Answered on June 09, 2015 at 03:29 PM

    Thank you for contacting us.

    Your form is currently embedded with a stable iFrame code. The form is operating normally on my side. Please recommend the form user to clear browser cache and cookies to see if that makes any differences.

    If this does not help, please let us know. We will be happy to help.