Unable to save forms if field conditions are included when duplicating multiple fields

  • Profile Image
    Asked on June 10, 2015 at 10:24 AM

    I have had three forms not save my progress and I have had to re-do the work I thought I had saved.

    I sometimes get this error:

  • Profile Image
    Answered on June 10, 2015 at 01:12 PM

    Our apologies for the inconvenience caused. Unfortunately, our forum cannot accept inline image attachments. Please check this guide on how to add a screenshot to this support forum:


    Or, you can just copy the error message and post it here.

    But normally, that would happen when your current session have timed out. You need to make sure that you are still logged into your account. If that keeps happening even if you are already logged in, then please try doing the following:

    a. Log out from your account

    b. Clear your browser's cache

    c. Clear your cookies for Jotform

    d. Login again

    e. Clear your form's cache: http://www.jotform.com/help/229-How-to-Clear-your-Form-Cache.

    d. Edit the form and save it again.

    If, for some reason, the issue is still there after doing the above steps, then please do the following and report back to us:

    a. While in the Form builder, press F12 to open the developers window

    b. In the developers window, find and click the "Console" tab.

    c. Look for the errors, usually in red color. Take a screenshot and post it here. 

    I would also suggest using another browser to see if the problem also happens there. If you also lost some changes in the form, you can revert it from the form revision history. Here's how: http://www.jotform.com/help/294-How-to-View-Form-Revision-History.


  • Profile Image
    Answered on June 10, 2015 at 02:10 PM

    I have done all the cache clearing , logged out and reclogged in - I even restarted my computer - and I just made some changes to my form and it will not save.

    When I click the save button and it does not show the circle and progress of the save it does nothing.

    When I try to navigate away from the page I get the warning that there are items that have not been saved - but it will not allow me to save.

    I have tried it in Firefox and still get the same error. 








  • Profile Image
    Answered on June 10, 2015 at 02:23 PM

    Did you try it with another browser? If you don't mind, please try it as well in Incognito (Chrome) or Private Browsing mode (Firefox).

    Can you send us a screenshot of the Console window as requested?

    We can forward this thread to our developers, but we need to know what are the errors that appeared in the console window. 


  • Profile Image
    Answered on June 10, 2015 at 02:25 PM


  • Profile Image
    Answered on June 10, 2015 at 02:28 PM

    I have tried it in Firefox and still get the same error. 



  • Profile Image
    Answered on June 10, 2015 at 03:34 PM

    We would like to apologize for any inconvenience this have caused you. Have you tried using the Revision History feature that my colleague, Welvin, have suggested? Because that may solve the issue you're having. 

    You can revert back where the form was working properly. then try to update the form again and save the changes this time after using the Revision History feature.

    Let us know if it helps. We will wait for your response. Thank you.

  • Profile Image
    Answered on June 10, 2015 at 05:43 PM

    Hi there -

    I appreciate all of your help...

    I did do this - then got the same error.. #CaVb5fxs3BxVEbI

    I cloned the survey and go this error

    I started from scratch a brand new survey and got this error.

    I do not get this error when I make changes and save them to other forms - which is why I started from scratch - but it does not like this form...


  • Profile Image
    Answered on June 10, 2015 at 06:18 PM


    Can you please share to us the URL of your form that was having this saving error issue?

    You have a lot of forms already, and I could not pinpoint which of the form you have shown in your screenshot


    Tell us the URL and we will focus check on that specific form issue.




  • Profile Image
    Answered on June 11, 2015 at 12:42 AM

    here is the URL - http://form.jotform.ca/form/51606403861249


  • Profile Image
    Answered on June 11, 2015 at 05:03 AM

    I have cloned mentioned form and I was not able to reproduce mentioned problem on my cloned form when I added new text box fields, I saved changed without any problems. 

    Here is my cloned form with new fields. http://form.jotformpro.com/form/51612465129958? 

    It is possible to receive this error while working on forms when there is an element in the form still updating when you press save.

    Are you unable to save at all?

    Maybe you can try to clone that form and then try to modify cloned form. 


    Hope this will help. Let us know if you need further assistance. 

  • Profile Image
    Answered on June 11, 2015 at 09:38 AM

    Thanks - I sent you a URL to the third version of the form - I cloned the original once - got the same error - rebuilt it all from scratch (that is the URL I sent you).

    I worked on it last night and continued to get the error - saving none of the work I was doing.

    It seems to crash when I am managing multiple fields...

    I am not sure if that has anything to do with it.

    I can edit text boxes and add new fields and save with no issues - but once I start duplicating groups of fields it pops up with that same cryptic error. and all is lost.


    Am I asking it to do too much??? is there a limit to how many fields can be duplicated at once?

    I have had the same issues again this morning.

    Many thanks



  • Profile Image
    Answered on June 11, 2015 at 11:08 AM

    i now get a new error... says a script is running...

    Can this be the issue?


  • Profile Image
    Answered on June 11, 2015 at 11:44 AM

    Thank you so much for the update. I was able to reproduce the issue you're having. I have cloned your form and I have noticed that your form has multiple sections and each section has similar fields like others.

    Because of that, I assumed that those were the fields that you're trying to duplicate per batch or at once. Then you'll just have to update the headers.



     You will see that the fields were duplicated successfully.

    However, when you save it you will be getting the same error message every time and the Save button will start not to work:

    This happens because when you have duplicated the fields you have included duplicating the conditions and failed to update it before saving the form. 

    Try not to include the conditions when you duplicate your fields:

    Once it's duplicated, save your form first. You can then edit the fields produced after duplication. Then, just recreate your conditions manually for the duplicated fields and save your form again. 

    I hope this helps. Kindly let us know if you still encounter the same issue. We look forward to your response. Thank you. 

  • Profile Image
    Answered on June 11, 2015 at 04:17 PM

    Hi there

    I tried duplicating with no conditions and the script is running issue now continues to pop u and I cannot save as the program stops running and shuts down.

    I cleaned up the conditions and I am still not able to complete the form.

    I have gone back to Adobe Forms Central for one last form as this was supposed to be out on Monday.

    I want to ensure that no issues like this will repeat themselves can you shed some light on the script that is running pop up?

    Much appreciated.

  • Profile Image
    Answered on June 11, 2015 at 05:57 PM

    I was able to duplicate fields inside of my cloned form like my colleague suggested, without conditions. And I was able to save form after.

    What browser are you using? I am using Chrome. Maybe you can try with different browser.

    You can also try to clone that form and then use Field Manager app to merge two forms into one form.

    Hope this will help. 


  • Profile Image
    Answered on June 12, 2015 at 04:25 PM

    I have cloned the new form three times and am trying to break this into three forms.

    Network Reporting 1, Network Reporting 2 and Network Reporting 3

    I have gone in and tried to delete fields in each but...

    Now my save is not working - I don't get the spinning gears or the Working message in the bottom right.

    When I navigate away from the page it says that unsaved changes will not be saved.


     still having issues....


  • Profile Image
    Answered on June 12, 2015 at 05:38 PM

    I checked the 3 forms which I assumed was the forms you were having issue with.




    All 3 forms loaded properly on my browser.


    When I navigate away from the page it says that unsaved changes will not be saved.

    To avoid this problem, we recommend NOT using the Form Builder in multiple instance. That is, do not open the Form Builder in your browser more than 1 times. 

    Since the Form Builder will auto save all the time, if you have opened the forms in multiple browser on the Form Builder, the latest saved version will always be the version the form will have.

    I also noticed that you have a very large form here http://www.jotform.ca/form/51626666152255

    Since it has a lot of contents, it will some times take a while before it complete loads on the browser most especially if the internet connection is not that fast. Make sure to only modify/update the form in the Form Builder after it had been completely loaded. When saving, make sure the saved button had already completed the save process before doing next action.

    Hope this help. Let us know which of your form you are still having issue with.