Language tool: Unable to save translations due to sign symbol like ampersand

  • Profile Image
    hwright
    Asked on June 13, 2015 at 09:43 PM

    Hi,

     

    If you have a form that has a field with an & in the description it appears that jotform is unable to save the alternative language for that field.

    In this form http://www.jotform.com//?formID=42977659134973

    I had a field called "Guest Profile & Demographics". I inputted the translation to chinese and saved it however JotForm never saved the translations. When I renamed the field to "Guest Profile and Demographics" then jotform would successfully save the translation.

     

    Regards,


    Heath

  • Profile Image
    Jan
    Answered on June 14, 2015 at 10:19 AM

    Are you saying that you cannot saved a translation? I cloned your form and tried to change the translation and I didn't encounter any problems.

    I also tried changing the text and saved the form. When I previewed it, it was successfully changed.

    Can you please provide more details about the problem so that we can further assist you. Thank you.

  • Profile Image
    hwright
    Answered on June 14, 2015 at 06:16 PM

    Change the name of the field to "Guest Profile & Demographics" and then try again. You will notice that the translations won't save for that field. Basically if appears that if you have an ampersand "&" in the field name then the translations won't save.

    Here is a cloned copy of the form with that modified. http://www.jotform.com/?formID=51647178197972

     

     

  • Profile Image
    jonathan
    Answered on June 14, 2015 at 07:52 PM

    Yes, it is possible that certain symbol/sign (i.e & ampersand) will cause issue to the language tool.

    I suggest you update the label/question name of the field and change the symbol to a proper name text.

    I test this on my test form and it fixes the issue.

     

    Hope this help. Let us know if you need further assistance.

    Thanks.

     

  • Profile Image
    siemonco
    Answered on May 17, 2017 at 03:28 PM

    That doesn't work in my case.

     I have a form in several languages and have no problem saving in Chinese, Japanese, etc, but when I get to Russian and French, it will automatically do the translations at first, but after I fill in blanks my changes won't save and all of the others are wiped out as well.  There are no symbols in any field names.  Any suggestions?  I tried deleting and rentering the languages, but it does the same thing every time.

     

  • Profile Image
    jonathan
    Answered on May 17, 2017 at 03:34 PM

    @siemonco

    We will resolve your issue on your thread here https://www.jotform.com/answers/1147419