All answers in the input field of the Passage Test Widget are the same, but it's not when filling up the form

  • Profile Image
    cultad
    Asked on June 14, 2015 at 01:37 AM

    http://form.jotformpro.com/form/51559031486963

    I am able to take the quiz and enter the text, but it only shows "renal": on all the answer sheets when opened as pdf file. It will not take all of answers. Only "renal" repeated in all the answer fields.

    Please check and let me know what I did wrong. Thanks.

     

     

  • Profile Image
    Welvin
    Answered on June 14, 2015 at 11:10 AM

    I think this is because your field names are all or almost the same. You have {FieldName} only in the settings. You should add a unique identifier for each input field. Please do it like this:

    {FieldName1}

    {FieldName2}

    ...and so on.

    Please do this for every field. I have just tried it and it works great. Here's a screenshot:

    Thank you!

  • Profile Image
    Welvin
    Answered on June 14, 2015 at 11:14 AM

    By the way, I have removed the used limit for my test submissions to your account. Also, here's the screenshot of the PDF file of my test form submission:

    It fails because I didn't provide the correct answer, but as you could see, they aren't the same. So, you just really need to provide a unique ID for each field input.

    Thanks

  • Profile Image
    cultad
    Answered on July 17, 2015 at 01:14 AM

    Is there anything else I need to add here

    {FieldName1}

    other than the FieldName1, etc?

  • Profile Image
    ashwin_d
    Answered on July 17, 2015 at 05:09 AM

    Hello cultad,

    No you do not have to add anything else other than unique field names withing the braces and the correct answers.

    I did check your form and now it seems to have unique field names which is correct and it should work as expected:

    The urinary system is also known as the  {FieldName1:12: renal system} system. The urinary system removes {FieldName2:30: excess water and waste products} and regulates the level of substances in the blood called {FieldName3:15: electrolytes}.

    The email & PDF output also seems to display correctly in my test form. Please check the screenshot below:

    Thank you!

     

  • Profile Image
    cultad
    Answered on July 17, 2015 at 09:22 AM

    I entered the correct answers but still shows Fail.

    So it's not taking the correct answers?

  • Profile Image
    Boris
    Answered on July 17, 2015 at 11:22 AM

    I see that you have added an empty space just before each of the correct answers:

    Please remove the spaces between the colon (:) and the answer in all 3 Passage Test widgets, and Save your form. After removing the accidental spaces from your answers, it seems to work correctly for me:

    I hope this helps. Let us know if you need further assistance.