Blocks being hidden incorrectly by conditions

  • Profile Image
    oandb
    Asked on June 15, 2015 at 02:14 PM

    Form:  Internet Marketers Self Assessment

    http://www.jotform.com//?formID=51114586739360

    I've been creating quite a large form with complex calculations and I'm now working on conditions for showing/hiding certain blocks (the pink ones - see my form).

    Something very odd is happening: when I preview the form, the pink blocks are being hidden before I enter anything at all on the form.

    I've created a video to show exactly what's happening:

    http://screencast.com/t/cHuEt2sU

     

    Thanks for your help.

     

    Alex

  • Profile Image
    Mike
    Answered on June 15, 2015 at 03:55 PM

    Thank you for contacting us.

    Please remove the Hide rules condition in order to fix the issue. In our system, when you add the Show/Hide conditions corresponding (mirror) Hide/Show conditions are not required.

    Once you delete the Hide rules conditions, the form should honor the Show conditions.

    If you need any further assistance, please let us know. We will be happy to help.

  • Profile Image
    oandb
    Answered on June 16, 2015 at 02:44 PM

    That worked - thanks.

    That's a nice facility, but not obvious. Is there some documentation that I missed?

     

    Thanks

     

    Alex

  • Profile Image
    Mike
    Answered on June 16, 2015 at 03:08 PM

    You are welcome. I do not think that you have missed any documentation here. The conditions were originally designed to work in that way, and they might be quite tricky sometimes.

    Please feel free to contact us if you notice any issues.