Submitting clears conditionally hidden fields of all values

  • Profile Image
    behedwin
    Asked on June 16, 2015 at 06:27 AM

    How do i make it so that all fields that i have filled in are submitted when i press the submit buttom?

    I have first a option of what part of the form the user want to fill in.

    So i have set a condition to show fields when they select one of the options.

    But when i submit only the current visiable options show in the answer.

    How can i keep all answers?

     

     

  • Profile Image
    Boris
    Answered on June 16, 2015 at 09:38 AM

    If I'm not mistaken, it should be forwarding even conditionally hidden fields to your View Submissions page and to your Email Notifications, unless you have accidentally Enabled the option to Clear a field on hide.

    Do you see the entries on your View Submissions page?

    I have raised this to our developers, so that they can take a closer look into this. Thank you.

  • Profile Image
    behedwin
    Answered on June 16, 2015 at 02:29 PM

    I have found the option "clear a field on hide" and have disabled it.

    Still when i save a form (submit)

    the answers that were selected on things that are hidden when the submit button is pressed will not be recorded on email, pdf or in the UI

  • Profile Image
    Sammy
    Answered on June 16, 2015 at 03:13 PM

    The issue you have raised is currently under active investigation, kindly bear with us as we await an update from our developers.

    You will be updated via this thread.

  • Profile Image
    behedwin
    Answered on June 22, 2015 at 07:57 AM

    Amazing, thanks allot. Will test this option and if i still have problems ill get back to you :)

     

     

  • Profile Image
    Ben
    Answered on June 22, 2015 at 09:06 AM

    In my colleagues name, you are welcome. If you still have any issues feel free to contact us back on this thread as you said, and we would be happy to assist with them.

  • Profile Image
    Double_Reading
    Answered on August 15, 2015 at 10:08 AM

    Hi,

    I'm having this same problem, even though it's set to 'Don't Clear'. I'm using the Recorder Widget, but I only want the user to make one recording. I have a rule set up that after the field is filled (by pressing STOP), the recorder hides itself. It does seem to complete the "Saving" routine, so I'm unsure as to why I'm not getting the recordings under 'View Submissions'.  

    http://form.jotformpro.com/form/52263209475961

    Thanks and kind regards,

     

    Jack

  • Profile Image
    Boris
    Answered on August 15, 2015 at 11:58 AM

    Jack, please note that your question has been moved to its own thread, so that we can troubleshoot the issues you are experiencing with the Recorder Widget and better assist you. It can be found here:

    http://www.jotform.com/answers/639697

    We will be assisting you there. Thank you.