Feedback button not working on Wordpress 4.2.2

  • Profile Image
    jgperrin
    Asked on June 18, 2015 at 09:41 AM

    Hi,

    I add my form and it appears on the contact buttons but I can't write in the different input.

    I use feedback button and embed forms.

    What happening ?

  • Profile Image
    Charlie
    Answered on June 18, 2015 at 10:23 AM

    Upon checking your website, I see you have multiple form embed codes that you are using. Is that right?

    I see you have used the Wordpress Feedback button

    And I see you are using a <script> code.

    I assume that script code refers to this one:

     

    If you have embedded the same form, it's possible that they are conflicting with one another. 

    I would advise that you try removing the one embedded on the website itself. After that, try testing the Feedback button, if it works then there's a conflict.

    If there's a conflict, you try these methods to avoid or prevent it:

    Method 1: Embed the form (not the feedback button form) using the iFrame code, that should prevent any code conflict.

    Method 2: If you can wrap it using jQuery noconflict, try it also.

    Do let us know if that works.

    Thank you.

  • Profile Image
    jgperrin
    Answered on June 18, 2015 at 11:14 AM

    Thank for your response,

    I try to deactivate one plugin first and the other no result.

    With all jotform plugin deactivate, I use a scrypt or a Iframe, no result.

    But If I change my theme (with default wordpress theme) it's work.

    What cause in my theme can do this issue ?

  • Profile Image
    Charlie
    Answered on June 18, 2015 at 11:56 AM

    There might be problems with the theme you are applying, or it is more likely a code conflict as I've mentioned earlier.

    I've checked your website again, and I don't see the feedback button anymore. Also, the form in your website is unclickable. May I know what you are seeing if you just use the feedback embed code?

    May I also know how you embedded the iFrame in your website? If you could share a screenshot of the text area where you pasted it, that would help us.

     

    Also, please try the methods mentioned here: http://www.jotform.com/help/324-A-Guide-To-Forms-For-WordPress-JotForm-Users. See which one works.

    I assume the original problem was just about the two forms being embedded on the same webpage. But now I'm quite confused which doesn't work. Regardless, we'll try to find the culprit of this problem.

    We'll wait for your response.