Cannot save a form on Google Chrome

  • Profile Image
    Asked on June 22, 2015 at 05:04 AM

    Good morning, I am working on some forms at the moment which we will eventually be using for order forms for particular customers, The jotform system is fantastic and I am really enjoying using this instead of formscentral, however, I have run into a couple of problems;


    1: When I use the check box function, I have been deleting the multiple options and leaving the first one blank, it I then set up a condition where if someone checks the box, it will open up further options, this works well so far, but when I save the form and come back to it later, it has reverted to having all 3 check boxes with option 1, option 2 and option 3 written in them.


    2: a couple of times now I have gotten to a certain point and found that the save icon is just stuck in 'saving', unfortunately it doesn't save the information and if I close the window I lose all the work, I have lost large chunks of my work twice this way, I left it 'saving' on Friday and came back to it this morning and it still hadn't become unstuck, as you can imagine it is extremely frustrating!


    If there is any way of stopping these thing happening? I cant let customers use the forms until I am sure they will stay the way I intend them to


    Kind regards


    Daniel Callaghan

  • Profile Image
    Answered on June 22, 2015 at 07:50 AM

    Hi Daniel,

    Thanks for contacting us.


    I cloned your form and was not able to replicate the issue. Can you provide us the browser version and device you are using when you encountered this issue so we can further check? We recommend you to use Mozilla Firefox and Google Chrome when using Form Builder. I cleared your Form's Cache to see if it helps.


    We will wait for your response.




  • Profile Image
    Answered on June 23, 2015 at 05:14 AM

    Good morning, I am having the same problem with the saving again, it has been stuck saving for a couple of hours now, I really don't want to have to redo all this work again, I am using Google Chrome and Windows 7

  • Profile Image
    Answered on June 23, 2015 at 06:51 AM

    I am sorry for the inconvenience that this is causing you, Daniel. I have cloned your form and tried to replicate the issue, but I wasn't able to replicate it. I have tried adding a couple of new Conditions to the form, added a field, deleted another field, and couldn't replicate the saving problem.

    Is there anything in particular that you have added or modified on the form when this happens?

    I have cleared your form cache to see if it helps, and I would also recommend that you please try clearing your browser cache as well.

    Please let us know if the issue persists, and it would help us try and recreate the problem if we knew the steps it takes to encounter it. For example, does it happen when you are adding / modifying Conditions, adding Calculations to your form, adding a Payment Tool, etc. Thank you.