Form Designer does not load from secure site but seems to from non-secure site

  • Profile Image
    Tiago Mali
    Asked on June 24, 2015 at 09:52 AM

    Every time I try to change the design of a form using Jot Form Designer Theme, instead of seeing my form I see a sample (it is happening in verey form):


    It doesn't matter if I try to change this sample options, it does not change anything in the design of my form. This is making impossible for our company to create new personalised forms as we used to do before. Please help us to solve this problem asap. We started paying the monthly fee because we were able to edit this forms. But now this is impossible.

    As an example, take this form:

    When we open at the Desginer, what appears is this:

    And I cannot change anything at all!

  • Profile Image
    Answered on June 24, 2015 at 11:14 AM

    Firstly, you have to log in using your user name tiagomali and your password, after that you will have acces to all forms of the account.

    I have cloned the above mentioned form , after testing this is the result I had:

    1 - This is your form in edit mode from Jotform form builder:


    2 - This is your form in Designer mode:


    3 - Access Jotform and Login:

    I hope this information helps. Please let us know if we can further assist you.

  • Profile Image
    Answered on June 26, 2015 at 05:18 PM


    You didn`t get the same thing because the error somehow dissapeared before you answered me. All the very basic information that you pointed have nothing to do with the problem. The thing is that the problem dissapeared before you saw it (I thought you guys had fixed it, but apparently not).

    But now it is happening again anda I really would like this to stop. I`ve cloned this form:

    The cloned form, which I want to make changes, is this one:

    But every time i make changes in Jot Form Designer to the cloned form (background image, for instance), it also changes the original form. As the original form has to coexist with the cloned one, this is really bad to us. Another thing is that there is a bug in the Jot form which doesn't allow me to click in the "Back to Builder" button when working in the Jot Form Designer.

    If I switch the browser (from Chrome to Firefox), it happens to appear the same sample screen the other time. Yes, I`ve logged in. It appears to be a bug over there.

    The thing is that the last time the problem was solved without me (or you guys) doing anything after one day. But now, it is happening again. Please, even if when you see this it's not happening anymore I cannot stay hoping for the best and wishing to be lucky. Please investigate this further to really solve whatever it's happening whenever I clone a form. I already tried to clear the forms cache and it doesn't bring any help.







  • Profile Image
    Answered on June 26, 2015 at 07:14 PM


    I just checked the designer and it appears to be working from the regular site:

    Instead of any other place.  If you from the link it does not look like it is working. I get stuck on this page.

    I will forward this to our development team to have a closer look.  in the mean time, try the link above and use the designer from there.  It should be working in both Chrome and FireFox.\

    We will update you here as soon as we have any further information

  • Profile Image
    Tiago Mali
    Answered on June 30, 2015 at 07:59 AM

    Thank you, it`s working now. But really hope next time I need to clone a form (and it will be shortly) you have fixed it for good and this doesn't happen again.



  • Profile Image
    Answered on July 02, 2015 at 02:16 AM

    The issue has just been fixed.

    Thank you!