Embedded Form not displaying on Website when viewed on iPad

  • Profile Image
    TonSee
    Asked on June 29, 2015 at 05:14 AM

    No form is working on a iPad (iOS 8). We have a lot of customers who are not amused!! I checed it on my own iPad, and don't see no forms.

     

    Regards,

     

    Ton

  • Profile Image
    Boris
    Answered on June 29, 2015 at 09:23 AM

    Ton, I'm afraid that I do not have an iPhone/iPad to check up your website, but I have asked one of our colleagues that does to help with taking a look on such a device.

    I have still taken a look at your website on a non-iPhone device, and I can see both the form and your website, although they do not appear perfect on a mobile.

    The form appears fine and responsive for me when accessed directly from its link:

    http://form.jotformeu.com/form/50714510872350

    Please allow us some time, so that I can confirm with my colleagues how it appears on an iPhone/iPad, and to see if there is something we can do on our end to help.

  • Profile Image
    TonSee
    Answered on June 29, 2015 at 09:33 AM
    New response receivedHello,
    Thanks for your respons. But, understand that it’s very important that it works on a iPad, one of the most used tablets.
    I understand you need some time, but I hope you have to find the solution soon as possible.
    Regards,
    Ton
    ...
  • Profile Image
    KadeJM
    Answered on June 29, 2015 at 10:25 AM

    I've inspected your issue further on my own iPad and found your form is working normally by itself as a standalone so we know its not our form that's the issue. Because so far this is only happening on your website from what I can see on my end after investigating this problem more.

    I found that you are using the standard embed script and since it's not working on your website I am convinced there is likely a conflict between the form and your site scripts that is preventing it from working properly.

    I would suggest that you re-embed your form using our iFrame Method as that should resolve it since it would wrap your form in a protective frame to prevent the conflict from occurring so that your form can then function properly.

     

    Your Form on iPad (Works):

     

    Your Form on Your Website(Doesn't Work):

     

  • Profile Image
    TonSee
    Answered on June 30, 2015 at 03:53 AM
    New response receivedHi,
    I found something strange. In other website of us, the forms will work well. So I made in the website who gives problems a new blank page with only the form. And here it works well. So, I think there is a conflict in the code of Muse. Before there was the form of Adobe FormCentral, which I replaced by JotForm.
    What I have done. I copied the page dem-dagen.html which contains the ‘problem’ form. Now the form is working, but NOT well!! The layout on the iPad (Safari and Chrome!) isn’t the same as in the desktop browser.
    Desktop:

    iPad (Safari and Chrome)

    Regards,
    Ton
    ...
  • Profile Image
    Welvin
    Answered on June 30, 2015 at 08:21 AM

    This support forum cannot accept inline image attachments so your images don't appear here. Please post it using this method: http://www.jotform.com/answers/277033.

    But I see that the responsive option is not checked in your form so I did. Can you check it again?

    Thanks