What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Form Not Submitting

    Asked by NekoStudios on June 30, 2015 at 04:33 AM

    I fill out the form, I press "submit my request" and nothing. It doesn't say "please wait..." or anything, it just freezes. The text in a text field would turn grey and nothing happens :/.

    http://www.jotform.us/form/51762791049159

    form not submitting JotForm text field please wait Freezes
  • Profile Image
    JotForm Support

    Answered by Welvin on June 30, 2015 at 09:17 AM

    Just so you know that I'm checking this now. I can't seem to find the exact cause, but I think this is something related to your conditional logic because if you disable them all, the submit button will work.

    Thanks

  • Profile Image

    Answered by NekoStudios on June 30, 2015 at 03:39 PM

    Is there anyway to determine which condition? I've been looking through them and cycling some of them and can't find the problem.

  • Profile Image
    JotForm Support

    Answered by jonathan on June 30, 2015 at 05:15 PM

    You can open the form's fields conditional statement associated to a specific field by clicking on the Conditions icon of the field. This will make it easier to review the attached condition rules.

     

    Example: I found an issue with your conditional statement for the Service password field

     

    it doesn't work properly on the live form http://www.jotform.us/form/51762791049159

    correcting the Conditional statement should help fix the issue.

    AND I also suggest disabling the Autofill feature on the form 

    It is highly possible the autofill feature saved cache is interfering with the conditional statements on the form. Disable the feature and check the form again.

    Hope this help. Please let us know if issue persist.

    Thanks.