Jotform keeps on crashing when you click the Pencil icon to edit an existing Condtion.

  • Profile Image
    Asked on July 06, 2015 at 06:18 PM

    I am trying to update a condition and when I click on the pencil icon jotform crashes.


    The form is not live because it isn't working.

  • Profile Image
    Answered on July 06, 2015 at 07:24 PM

    I would like to apologize for the inconvenience this have caused you. 

    I understand that you're trying to update/edit existing conditions on your form using this icon:

    I have cloned your form and tried to click that icon on every existing condition, but I wasn't able to reproduce the issue you're having. 

    What browser were you using when this occurs? Is there a way for you to use a different browser to test if it will work there?

    You can also try to clone your form and see it will do the same on the cloned form. 

    If you have tried all this and you're still experiencing the same issue, please do get back to us and we'll try to figure this out for you and help you further. 

    Thank you. 

  • Profile Image
    Answered on July 06, 2015 at 08:15 PM

    Thank you for your reply.

    You understand me correctly :-)

    I have tried on Chrome and Safari on my macbook and my iMac.

    This is a clone of another form (hence why I need to make changes) but it has been happening a lot since the last Jotform upgrade.

    I create a new form every month for our dressage club and have been loving JotForms but since the upgrade I have been having this and a few other crashing problems.

  • Profile Image
    Answered on July 06, 2015 at 09:44 PM

    Is there any way possible for you to use a different computer like Windows and see if it will work there. As I have mentioned, I wasn't able to reproduce the issue and everything is working fine on my end. I'm using Windows 8.1 and Google Chrome. Here's is the cloned form I have used for testing:

    Upgrading your account has nothing to do with how you create your forms.

    What I would recommend for you to do, for now, is try to clear your Form's cache and check if that solves the issue. Here's a guide: How-to-Clear-your-Form-Cache

    Also, may we know what happens when it crashes? Does it show any error message? 

    Again, we would like to apologize for the inconvenience. We will wait for your response. Thank you.

  • Profile Image
    Answered on July 09, 2015 at 12:00 AM

    Thanks for your reply.

    When I click on the icon it starts to open the conditions wizard it just closes again and the form is darkened. I have to reload it.

    I have cleared the jotforms cache and the browser's cache.


  • Profile Image
    Answered on July 09, 2015 at 12:11 AM

    It seems to be the "Update a form field value". I just went through a few other forms and it only crashed when I tried to update a form field value.

  • Profile Image
    Answered on July 09, 2015 at 03:57 AM

    I see that there are a lot of conditions on your form that are targeting deleted fields - marked with red text. Please try disabling or deleting these conditions, and kindly let us know if this resolves the crashing issues for you.

    You can disable these conditions by clicking on their Pause icon (marked with 1), or remove them by clicking on their red minus icon (marked with 2).

    Please let us know how it goes.

  • Profile Image
    Answered on July 10, 2015 at 06:42 AM


    I have deleted/ fixed all the deleted fields.

    I had to clone my form as it is currently live for competition entries.

    the new link is

    It is still crashing.



  • Profile Image
    Answered on July 10, 2015 at 09:19 AM

    I am sorry, but I can't seem to replicate the issue. Would you mind telling us which condition exactly are you trying to edit when the form freezes/crashes for you?

    have cloned your latest form, and I have tried clicking on the Pencil shaped icon on every single condition, and couldn't replicate the issue. As my colleague Mike did before, I too have clicked every Pencil shaped icon to edit each of the conditions, and all of them opened fine for me.

    What did fall into my eyes is that you are Updating a field value with a "real" number in some conditions, while with a "textual" number in others.

    The "real" numbers are blue:

    The textual representation of these numbers is just text:

    This shouldn't really have any impact, but can you still please try changing all instances of your conditions that are using the textual numbers to the real numbers, which you can insert by clicking the numbers on the right.

    Conditions that have textual numbers in them are conditions number 4, 21, and 26. I hope this helps.

  • Profile Image
    Answered on July 11, 2015 at 08:41 PM

    Ok, I think I have learnt something!!!

    If I go into the long list of all the conditions I can change/ update the conditions no problem (YAY)


    But if I try to click on the green arrow thing in the element on the form then try to update it crashes!

    Does that make sense?

    So I click on this green arrow then when I click on update the form crashes.

  • Profile Image
    Answered on July 11, 2015 at 10:17 PM

    I suppose this is still happening on the cloned form you have created. 

    I was able to reproduce the issue.

    It happens only when you open your Condition on Full-Screen mode. It shows a darkened screen because the condition is, actually, being opened, but it was unsuccessful.

    Here's what you can do:


    And that's the time you click on the Pencil icon of the condition that you would like to edit. 

    Now if, for example, you accidentally clicked on the Pencil icon without turning off the Full-Screen mode. What you can do is press ESC key from your keyboard and just repeat the process. Or, if you're using Google Chrome, you can Show/Hide your Bookmarks by pressing Ctrl+Shift+B from your keyboard. See the image below. 

    I hope this helps. Let us know if you need any further assistance. Thank you.

  • Profile Image
    Answered on July 13, 2015 at 01:39 AM

    Thank you so much for your help. this has solved my problem