word press plug in

  • Profile Image
    olpevents
    Asked on July 15, 2015 at 10:30 AM

    I have a previous version of the WP plug in on my site. I was attempting to activate the new one I downloaded, and got this error:

     Fatal error: Cannot redeclare class JotFormWPEmbed in /var/www/vhosts/businesswomanpa.com/httpdocs/bw2014wp/wp-content/plugins/embed-form/jotform-wp-embed.php on line 12

    Can you help? Can I not have both versions? what will happen to the one I have installed with the older version if I delete and active new one?

     

    The one i have activated currently is: Version 1.52 | By Trevor Montgomery | View details

    The newest one I found, that I am trying to activate and get error is: Version 1.2 | By Ertugrul Emre Ertekin | View details

     

     

    thanks

  • Profile Image
    omur
    Answered on July 15, 2015 at 12:02 PM

    Hello,

    No you cannot have both versions because it will trigger the very same class declaration error.

     

    Why do you need both versions on your form, maybe we can help you on another way?

  • Profile Image
    olpevents
    Answered on July 15, 2015 at 12:06 PM

    I dont need both versions, but the original one that I have does not seem to be working when I click on the jot form icon to get to my forms.

  • Profile Image
    david
    Answered on July 15, 2015 at 01:26 PM

    The form should remain even if you remove the plugin.  I would recommend updating to the new one.  You can also try the direct embed method, rather than using the plugin:

    http://www.jotform.com/help/4-Adding-Forms-to-Wordpress-org-version

    The iFrame code occasionally needs to be used for that method, rather than the regular script embed that is shown in the guide:

    http://www.jotform.com/help/148-Getting-the-Form-iFrame-Code